Formules indicateurs

Messages postés
30
Date d'inscription
samedi 14 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2019
- - Dernière réponse : via55
Messages postés
11442
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 décembre 2019
- 25 nov. 2019 à 17:12
Bonjour,

J'ai divers besoins concernant un tableau excel

https://we.tl/t-DtOw46Dvfu

Feuil1 mes données

Feuil2 mes indicateurs
Il faudrait que j'ai en C6 : le nombre de personne ayant commencé la pièce avec le numéro de module donnée PC ou PH avec date présente dans L(feuil1)

D6 : PC ou PH terminée avec Une date dans L et N (Feuil1

En vous remerciant pour votre aide.
Afficher la suite 

2 réponses

Messages postés
11442
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 décembre 2019
1540
0
Merci
Bonjour,

En C6 :
=SOMMEPROD((Feuil1!$B$2:$B$1000=B6)*(Feuil1!$Q$2:$Q$1000="PH")*(Feuil1!$L$2:$L$1000<>""))+SOMMEPROD((Feuil1!$B$2:$B$1000=B6)*(Feuil1!$Q$2:$Q$1000="PC")*(Feuil1!$L$2:$L$1000<>""))
à étirer vers le bas

en D6 :
=SOMMEPROD((Feuil1!$B$2:$B$1000=B6)*(Feuil1!$Q$2:$Q$1000="PH")*(Feuil1!$L$2:$L$1000<>"")*(Feuil1!$N$2:$N$1000<>""))+SOMMEPROD((Feuil1!$B$2:$B$1000=B6)*(Feuil1!$Q$2:$Q$1000="PC")*(Feuil1!$L$2:$L$1000<>"")*(Feuil1!$N$2:$N$1000<>""))
à étirer vers le bas

Si ton tableau initial va au delà de la ligne 1000 modifier les références dans les formules en conséquence

Cdlmnt
Via
adribreizh
Messages postés
30
Date d'inscription
samedi 14 novembre 2009
Statut
Membre
Dernière intervention
25 novembre 2019
-
Bonjour,

Merci pour ton retour.
Désolé pour le retard de réponse
En indiquant la formule en C6 il me prend en compte le nombre total d'entrée alors que les personnes sont les deux même. Il m'indique 4 au lieu de 2

Pour la D6 cela semble être ok.

Cordialement,
Adrien
Commenter la réponse de via55
Messages postés
11442
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 décembre 2019
1540
0
Merci
Bonjour

Dans ce cas il faut avoir recours à une formule matricielle en C6 :
=NB(1/FREQUENCE(SI((Feuil1!$C$2:$C$17=Feuil2!B6)*(Feuil1!$L$2:$L$17>0)*((Feuil1!$Q$2:$Q$17="PH")+(Feuil1!$Q$2:$Q$17="PH"));EQUIV(Feuil1!$I$2:$I$17;Feuil1!$I$2:$I$17;0));LIGNE(INDIRECT("1:"&LIGNES(Feuil1!$I$2:$I$17)))))
à valider par Ctrl+Maj+Entrée, la formule se met alors entre accolades dans la barre de formules

Changer les références des plages pour un tableau plus grand mais limiter à la taille du tableai car les matricielles sont gourmandes en ressources

Cdlmnt
Via

Commenter la réponse de via55