Fonction si avec aujourd'hui

Signaler
-
PapyLuc51
Messages postés
2246
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
12 décembre 2019
-
Bonjour,
Je desire qu'une cellule se remplisse automatiquement avec "disponible"" indisponible" ou cellule reste vide en fonction d'une autre cellule contenant une date .

exemple:
- si la cellule en colonne C est superieur a la date d'aujourdhui cela me rempli "DISPONIBLE"sur la meme ligne en colonne A

- si la cellule en colonne C est inferieure a la date d'aujourdhui cela me rempli "INDISPONIBLE "sur la meme ligne en colonne A

- et enfin si la cellule en colonne C est vide cela me laisse la cellule vide sur la meme ligne en colonne A


Merci d'avance pour vos conseil

Configuration: Windows / Internet Explorer 11.0
Messages postés
16011
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 décembre 2019
2838
Bonjour

Et si la date en C =aujourd’hui ?
Si la date en C = aujourd'hui : disponible
Bonjour,
Vous pourriez essayer cette formule :
https://cjoint.com/c/IKwkn1nBCqK
Cordialement.
Messages postés
2246
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
12 décembre 2019
455
Bonjour à tous

J'y vais de ma petite formule

La date en C2

En A2 =SI(C2<>"";SI(C2<AUJOURDHUI();"INDISPONIBLE";"DISPONIBLE");"")

Pour raccourcir la formule inutile de mettre >=AUJOURDHUI()

Cordialement
Merci à vous tous cela fonctionne .

Maintenant je voudrais faire la même chose mais avec 2 variable :

- si la cellule en colonne C est supérieure ou egale à la date d'aujourd'hui ET la cellule en colonne D est supérieur ou égale également cela me rempli ^disponible^ en colonne A.

- si la cellule en colonne C est inferieure à la date d'aujourd'hui ET la cellule en colonne D est inférieure également cela me rempli ^indisponible^ en colonne A.

-si elle sont différente en colonne C et colonne D cela me rempli ^indisponible^ en colonne A.

Merci d'avance à vous .
Messages postés
2246
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
12 décembre 2019
455
Re,

=SI(C2<>"";SI(C2<>D2;"INDISPONIBLE";SI(ET(C2<AUJOURDHUI();D2<AUJOURDHUI());"INDISPONIBLE";"DISPONIBLE"));"")

Il faudra peut être affiner pour la condition C différente de D ;
c'est à dire C et D >=AUJOURDHUI() /ou/ C et D <AUJOURDHUI() /ou/ l'une des deux cellules est soit >= soit <AUJOURDHUI() car avec les deux premières conditions çà impose que C et D soient exactement identiques

Cordialement
Merci papyluc51 cela fonctionne parfaitement .

Seul un défaut persiste .

Si C est vide À est vide et si D est vide À inscrit indisponible.

Il me faudrait une solution pour que A inscrive dispo ou indispo en fonction uniquement de C si D est vide et inversement en fonction de D si C est vide.

merci d'avance .

Je sais que je vous en demande beaucoup.
Vaucluse
Messages postés
24738
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 décembre 2019
4918
bonjour
et salut Papy luc
Peut être comme ça:
=SI(OU(C2="";D2="");"";SI(C2<>D2;"INDISPONIBLE";SI(ET(C2<AUJOURDHUI();D2<AUJOURDHUI());"INDISPONIBLE";"DISPONIBLE")))
crdlmnt
PapyLuc51
Messages postés
2246
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
12 décembre 2019
455
Salut Vaucluse

Une petite rectification peut-être A2 doit rester vide si C2 et D2 sont vides

=SI(ET(C2="";D2="");"";SI(C2<>D2;"INDISPONIBLE";SI(ET(C2<AUJOURDHUI();D2<AUJOURDHUI());"INDISPONIBLE";"DISPONIBLE")))

mais je pencherai plutôt pour celle-là

=SI(ET(C2="";D2="");"";SI(OU(ET(C2<>"";D2="";C2<AUJOURDHUI());ET(C2="";D2<>"";D2<AUJOURDHUI()));"INDISPONIBLE";"DISPONIBLE"))

Cordialement