Problème formule + mise en forme [Résolu]

Messages postés
145
Date d'inscription
jeudi 19 mars 2009
Statut
Membre
Dernière intervention
28 novembre 2019
- - Dernière réponse : sev33000
Messages postés
145
Date d'inscription
jeudi 19 mars 2009
Statut
Membre
Dernière intervention
28 novembre 2019
- 21 nov. 2019 à 15:32
Bonjour,

1 - J'ai un souci dans le tableau que vous trouverez dans le lien ci-joint :

https://www.cjoint.com/c/IKvmUGBC4Yc

à savoir :

Dans ma colonne D, ligne 66, la somme de la colonne ne veut pas se calculer : j'ai beau chercher, à chaque fois le résultat me donne 0 alors qu'il devrait être de 848 419,32 €.

Si une âme charitable peut me trouver l'erreur, je l'en remercie.

2 - Dans ce même tableau, toujours en colonne D, j'aurais besoin de mettre une formule pour une MFC, qui dit :

- Si les colonnes E à Q = rien, alors il faut inscrire le montant de la colonne C
- et en plus, il faudrait que la cellule se mette en couleur (peut importe la couleur)

Et si une valeur est inscrite dans E à Q, alors D =MIN(E16:Q16) et on ne mets pas de couleur.

Ceci, en sachant que la colonne D contient, normalement, la formule =MIN(E16:Q16) (dans le tableau joint, toutes les cellules n'ont pas la formule car nous avons forcé pour pouvoir travailler en attendant une réponse).

En vous remerciant de votre aide.

Cordialement.
Afficher la suite 

1 réponse

Messages postés
24734
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 décembre 2019
4913
0
Merci
Bonjour
pour la colonne D, Excel vous annonce des références circulaires:
vous ne pouvez pas chercher le mini d'une plage qui contient la formule où vous voulez le résultat!
exemple en D23: miniC23:Q23 qui contient D23
etc...
pour la MFC
il faut d'abord mettre la formule qui dit que si E:Q = rien, alors C sinon mini E:Q
(soit par exemple en cC20 mais on ne sait pas très bien où vous voulez placer les résultats)
=SI(NB.SI(E19:Q19;">0")=0;C19;MIN(E19:Q19))
et la formule de MFC selon cette ligne:
=NB.SI(E19:Q19;">0")=0
crdlmnt


sev33000
Messages postés
145
Date d'inscription
jeudi 19 mars 2009
Statut
Membre
Dernière intervention
28 novembre 2019
-
Bonjour,

pour la colonne D, Excel vous annonce des références circulaires:
vous ne pouvez pas chercher le mini d'une plage qui contient la formule où vous voulez le résultat!
exemple en D23: miniC23:Q23 qui contient D23


=> Donc si je comprend bien, en changeant ma colonne D (moins disant) de place, et en la mettant en C, je ne devrais plus avoir ce problème ????
sev33000
Messages postés
145
Date d'inscription
jeudi 19 mars 2009
Statut
Membre
Dernière intervention
28 novembre 2019
-
J'ai essayé en le faisant et ça ne fonctionne quand même pas
sev33000
Messages postés
145
Date d'inscription
jeudi 19 mars 2009
Statut
Membre
Dernière intervention
28 novembre 2019
-
C'est bon.... j'ai essayé et tout fonctionne.

Merci de votre aide
Commenter la réponse de Vaucluse