Formule pour choisir une valeur dans un tableau

Signaler
-
via55
Messages postés
11460
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 décembre 2019
-
bonjour,

je suis novice sur excel, et j'ai cherché un bon moment sans parvenir à trouver la solution...

j'essaye de créer un tableau qui me calcule automatiquement mes frais de port, et pour cela je cherche une formule qui choisisse automatiquement dans mon tableau le bon montant en fonction du nombre de bouteille (une colonne pour 6, 12, 18, 24, 36 etc jusqu'à 600) et aussi en fonction de la zone ou se trouve le département ( une ligne par zone par exemple zone 1= département 26 en dessous zone 2 qui comprend les départements 04,05,07,38,42,69,84 et il y a 13 zones au total donc 13 lignes avec plus ou moins de départements.

La grille est déjà saisie et une fois que je saurait comment remplir automatiquement la cellule correspondant au montant des frais de port par bouteille et par département, je pourrais plus facilement ajouter la taxe gasoil, les frais d'enlèvement et tout le bazar, mais en attendant... ça coince un peu...

J'ai essayé les fonction cherche, les si multiples, si conditions... mais à chaque fois ça coince à partir du troisième choix.. voire ça ne fonctionne pas du tout.

quelqu'un aurait-il une solution pour m'aider?

Merci d 'avance et bonne journée!

3 réponses

Messages postés
24738
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 décembre 2019
4920
Bonjour
sans le modèle un exemple à adapter
dfeuil1 base de données avec: de A2 à A12: les n° de département
de B1 à N1 les nombres de bouteilles
et bien sur le tableau rempli avec les montants correspondants aux croisement ligne colonne
en feuil2 édition avec
en A2 le département
en B2 le nombre de bouteille
en C2 la formule:
=SIERREUR(INDEX(Feuil1!$B$2:$N$12;EQUIV(A2;Feuil1!$A$2:$A$12;0);EQUIV(B2;Feuil1!$B$1:$N$1;0));"")
avec en variantes possible si le nombre de bouteilles n'est pas exact par rapport au titre de n colonne, mais à condition que B1:N1 soit classé en ordre croissant:
pour avoir la valeur inférieure, la même sans le 0 à la fin:
=SIERREUR(INDEX(Feuil1!$B$2:$N$12;EQUIV(A2;Feuil1!$A$2:$A$12;0);EQUIV(B2;Feuil1!$B$1:$N$1));"")
et pour avoir la valeur supérieure, toujours sans le 0 à la fin, mais avec +1 pour décaler la colonne
=SIERREUR(INDEX(Feuil1!$B$2:$N$12;EQUIV(A2;Feuil1!$A$2:$A$12;0);EQUIV(B2;Feuil1!$B$1:$N$1)+1);"")
pour info:
le code SIERREUR(formule complète);"") est utilisable à partir d'Excel 2013 et sert à éviter un affichage d'erreur si A2 ou B2 sont vides
revenez en déposant un modèle si problème, ici:
http://mon-partage.fr
et en revenant coller le lien créé sur le site
crdlmnt
Messages postés
11460
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 décembre 2019
1546
Bonjour Aurelia
Coucou Vaucluse

Un petit exemple pour te montrer la procédure à suivre :
https://mon-partage.fr/f/ROCb3qda/

Cdlmnt
Via