Plusieurs conditions

Signaler
-
via55
Messages postés
11464
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 décembre 2019
-
Bonjour,
j'ai besoin d'aide , en effet j'aurai besoin d'un calcul qui prenne en compte plusieurs conditions :
Si une femme a déjà des enfants + le nombre d'enfants dont elle est enceinte + le congé prénatal .

Cela me permettra d'avoir automatiquement la date de début du congé avant l'accouchement (sachant que je connais la date d'accouchement.

Enfant(s) déjà né(s) Enfant(s) à naître Congé avant la naissance (prénatal)
Aucun 1 enfant 6 semaines
Aucun 2 enfants 12 semaines
Aucun > 2 enfants 24 semaines
1 enfant 1 enfant 6 semaines
1 enfant 2 enfants 12 semaines
1 enfant > 2 enfants 24 semaines
2 enfants 1 enfant 8 semaines
2 enfants 2 enfants 12 semaines
2 enfants > 2 enfants 2 4 semaines
3 enfants et + 1 enfant 8 semaines
3 enfants et + 2 enfants 12 semaines
3 enfants et + > 2 enfants 24 semaines

J'ai déjà un mais avec deux tableaux : - un pour les femmes qui ont 0ou1 enfants

-un autre pour les femmes avec deux enfants et plus

J'ai donc les calcul suivant comme base:

=SI(J4=1;" 6";SI(J4=2;" 12";SI(J4>2;" 24";"")))


=SI(J5=1;"8";SI(J5=2;"12";SI(J5>2;"24";"")))



Configuration: Windows / Internet Explorer 11.0

3 réponses

Messages postés
24738
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 décembre 2019
4922
Bonjour
vous devriez déposer un fichier anonymisé pour que l'on s'y retrouve dans vos données, parce que pour l'instant, à part penser que vous avez des clientes qui attendent plus de deux enfants, on a du mal à suivre!
ajoutez y quelques annotation et un tableau du barème et voyez ici:
http://mon-partage.fr
et revenez coller le lien créé sur le site
à vous lire
crdlmt

Messages postés
11464
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 décembre 2019
1548
Bonjour xx
Coucou Vaucluse

Il me semble que tout peux se résumer par une formule assez courte, avec le nombre d'enfants nés en B3 et le nombre d'enfants à naitre en C3 :
=SI(C3=1;6+SI(B3>0;2;0);SI(C3=2;12;24))

Cdlmnt
Via