Fonctions [Résolu]

Signaler
Messages postés
10
Date d'inscription
mardi 12 novembre 2019
Statut
Membre
Dernière intervention
22 novembre 2019
-
DjiDji59430
Messages postés
2527
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 décembre 2019
-
Peut-on mettre dans une même formule la fonction SI et la fonction TEXTE avec excel 2007
=SI(E15=0;"";TEXTE E15;"mmmm")
Soit, dans la cellule G15 : si la cellule E15 est vide, ne rien mettre, si elle est remplie: mettre le mois mmmm
Si je mets la formule: =TEXTE(E15;"mmmm" en G15 celà fonctionne très bien mais quand je tire ma formule vers le bas de la colonne et que il n'y a rien dans la colonne E, cela me met janvier, ce que je
voudrais éviter.
Merci d'avance si vous pouvez m'aider.
copo15

16 réponses

Messages postés
23125
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
5799
Bonjour à tous,

avec un TCD : https://www.cjoint.com/c/IKvm2LSsPy7
Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/smartsection/item.php?itemid=109
et
http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=130
eric

PS : si tu veux que tous les mois s'affichent, insérer une ligne avec juste une date du mois absent dans Mois
Ex avec 1/5/1900 dans D2 :
Civilité Nom Prénom Mois Ages
                    mai

et masquer ces lignes si besoin.


En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Copo15
Messages postés
10
Date d'inscription
mardi 12 novembre 2019
Statut
Membre
Dernière intervention
22 novembre 2019

Merci eriiic pour ton aide mais il va falloir que je me mette au tableau croisé dynamique
c'est encore compliqué pour moi.
DjiDji59430 m'a trouvé une formule à 99% parfaite.
Crdlmt copo15
eriiic
Messages postés
23125
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
5799
Il faut prendre 1/2h pour comprendre les bases des TCD.
Mais une fois acquises, quelle puissance et quel temps gagné.
C'est un investissement qui rapporte 10000%, tu refuses ? ;-)
eric
Copo15
Messages postés
10
Date d'inscription
mardi 12 novembre 2019
Statut
Membre
Dernière intervention
22 novembre 2019

Salut eriiic il va me falloir plus d'une 1/2h pour comprendre les TCD
mais je vais m'y mettre car comme tu dis quelle puissance !!!!
Crdlmt copo15
Messages postés
2527
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 décembre 2019
292
Bonjour à tous,

Si tu mets la bonne syntaxe, ça va fonctionner

=SI(E15=0;"";TEXTE(E15;"mmmm"))

Crdlmt
Messages postés
16016
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
13 décembre 2019
2841
Bonjour

E15 devrait être une date (si tu as 2 dans E15, Xl considère que c'est le 2° jour de l'année)

=SI(E15=0;"";TEXTE(DATE(1;E15;1);"mmmm"))

excuse moi, djidji, je n'avais pas rafraichi

DjiDji59430
Messages postés
2527
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 décembre 2019
292
Re
Avec le fichier, ça va mieux !

https://www.cjoint.com/c/IKvtafLFzwh


Crdlmt
Copo15
Messages postés
10
Date d'inscription
mardi 12 novembre 2019
Statut
Membre
Dernière intervention
22 novembre 2019
> DjiDji59430
Messages postés
2527
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 décembre 2019

Merci énormément DjiDji59430 , j'ai un petit souci en I3 pour janvier si je monte ma plage en: $E3:$E100
il me met 85 pour janvier, pour les autres mois pas de problème.
Le nombre de membre n'est pas connu et peut aller à 200.
Encore désolé de faire appel à tes lumières.
copo15 Crdlmt
DjiDji59430
Messages postés
2527
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 décembre 2019
292 > Copo15
Messages postés
10
Date d'inscription
mardi 12 novembre 2019
Statut
Membre
Dernière intervention
22 novembre 2019

Re
=SOMMEPROD((MOIS(Membres!$E$3:$E$100)=MOIS('Anniversaires '!H3&1))*(Membres!$E$3:$E$100<>0))

100, ou 200...


Crdlmt.
Copo15
Messages postés
10
Date d'inscription
mardi 12 novembre 2019
Statut
Membre
Dernière intervention
22 novembre 2019

Merci mille fois DjiDji59430 cela fonctionne très bien.
Mon problème est résolu (jusqu'au prochain !!!!!!
Crdlmt
copo15

Comment signaler que ma demande est résolue?
DjiDji59430
Messages postés
2527
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 décembre 2019
292 > Copo15
Messages postés
10
Date d'inscription
mardi 12 novembre 2019
Statut
Membre
Dernière intervention
22 novembre 2019

Re
Je m'en souviens plus, mais il me semble que c'est en haut, quand tu édites ton poste .....


Crdlmt