Figer une cellule en fonction de la date

Signaler
Messages postés
2
Date d'inscription
mardi 19 novembre 2019
Statut
Membre
Dernière intervention
24 novembre 2019
-
via55
Messages postés
11457
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
11 décembre 2019
-


bonjour,
j'ai un soucis pour figer des données au jour le jour :

j'ai une case "F5" qui est mise à jour chaque jour.


j'ai ensuite la ligne B qui correspond à chaque jour de la semaine. chaque cellule est, pour le moment un copier coller de la case "F5", donc, chaque jour, la cellule "F5" évolue, mais toutes mes cellules, y compris celle d'avant la date de saisie aussi.

je voudrais donc, que la cellule "B9" corresponde aux données saisies le 1er novembre et qu'elle reste figée lorsqu'on change de jour. le 2 novembre (aujourd'hui) le fait de changer la valeur "F5" change automatiquement la case correspondant à la date du jour, soit "C9" qui serait égale à "B9"+"F5"


en gros.... j'ai écrit ça en B8 : =SI($B2=B9;F5) donc : si "aujourd'hui"= "date du calendrier"(case en dessous B9) alors B8 sera égale à F5. je voudrais que le lendemain (la formule sera donc fausse) "B8" soit toujours égale au résultat de la veille, soit "2" dans mon exemple.
et donc la case d'après (C8) sera F5+B8 avec cette formule : =SI($B2=C9;B8+$F5;B8)
en l'état actuel, si je tape la date du 02/11 en B2, mon calcul en B8 devient "FAUX".

en laissant "2" en "F5" il faudrait que j'ai "2" en "B8" et "4" en "C8", etc.

merci si vous avez une solution si possible sans macro, bien que ça me semble compliqué !!!
Messages postés
2246
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
12 décembre 2019
455
Bonjour,

Sans macro, je ne pense pas que se soit possible.

Un petit exemple de ce qu'il est possible de faire avec des formules et des MFC (la petite macro installée ne sert qu'au bouton Effacer qui agit sur la ligne 11)

https://www.cjoint.com/c/IKtlhfawM1Q

Cordialement
12seb12
Messages postés
2
Date d'inscription
mardi 19 novembre 2019
Statut
Membre
Dernière intervention
24 novembre 2019

bonjour,
merci pour ta réponse. il est important d'imaginer le soucis sous différents angles. ta solution n'est pas celle que j'attendais, mais peut me servir pour ce dossier ou un autre.
merci,
seb.
Messages postés
11457
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
11 décembre 2019
1546
Bonjour

Oui impossible sans macro
Exemple avec macro
https://mon-partage.fr/f/eYEwFpb2/

Cdlmnt
Via