GOOGLE SHEET - Décrémenter du texte d'une cellule

Signaler
Messages postés
3
Date d'inscription
lundi 18 novembre 2019
Statut
Membre
Dernière intervention
18 novembre 2019
-
PapyLuc51
Messages postés
2254
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 décembre 2019
-
Bonjour à tous,

Mes notions basiques de google sheet ne me permettent pas de résoudre mon casse tête.. :(

https://docs.google.com/spreadsheets/d/1sYTBzi_kW2rkPcjzvZO1CkRo9_PVpoPM33wD8Lm07xY/edit?usp=sharing

Je suis entrain d'établir un planning d'activité et j'aimerai pouvoir décrémenter le texte de la cellule C1 lorsque celui ci apparaît dans l'une des cellules E3 ou E4 ou ... ou E9.

Si quelqu'un a une solution cela me serait d'une grande aide :)
D'avance un grand merci.

Laurent.

6 réponses

Messages postés
2254
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 décembre 2019
456
Bonjour

J'ai tenté cette formule sur excel ; à voir si elle convient

En C1

=SI(NB.SI($E$3:$E$9;"AA")>0;"";"AA")&" "&SI(NB.SI($E$3:$E$9;"BB")>0;"";"BB")&" "&SI(NB.SI($E$3:$E$9;"CC")>0;"";"CC")&" "&SI(NB.SI($E$3:$E$9;"DD")>0;"";"DD")&" "&SI(NB.SI($E$3:$E$9;"EE")>0;"";"EE")

Cordialement
LAUSAMP
Messages postés
3
Date d'inscription
lundi 18 novembre 2019
Statut
Membre
Dernière intervention
18 novembre 2019

Bonjour PapyLuc51,

Après essai, a priori votre formule fonctionne parfaitement.
Pour le novice que je suis, elle apparaît très compliquée mais je pense que je saurais la manipuler et la modifier au besoin.

Un grand merci pour votre aide ! :)
Bien à vous,
Laurent.
PapyLuc51
Messages postés
2254
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 décembre 2019
456 > LAUSAMP
Messages postés
3
Date d'inscription
lundi 18 novembre 2019
Statut
Membre
Dernière intervention
18 novembre 2019

C'est une concaténation on ajoute des textes les uns derrière les autres d'où la présence du signe &
Chaque formule détermine la présence ou non du groupe de lettres
SI(NB.SI($E$3:$E$9;"AA")>0;"";"AA") veut dire si dans la colonne E le nombre de AA et supérieur à 0 alors on laisse vide sinon on inscrit AA
&" "& veut dire qu'on ajoute un espace entre chaque groupe de lettres

En espérant avoir bien expliqué ce que tu cherche à comprendre.

Si le sujet est résolu alors clique sur la roue dentée à droite du titre pour confirmer

Cordialement
LAUSAMP
Messages postés
3
Date d'inscription
lundi 18 novembre 2019
Statut
Membre
Dernière intervention
18 novembre 2019

Effectivement. Merci pour votre éclaircissement :)
Peut être pourriez vous m'aider sur une deuxième problématique ?
Je souhaiterais empêcher la possibilité de taper deux fois le même groupe de lettres dans 2 cases différentes de la colonne E. Cela afin d'empêcher les doublons d'attribution de tâche.

Pourriez vous m'aidez ?
D'avance merci.
Laurent.
Messages postés
2254
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 décembre 2019
456
L'empêcher par formule je ne sais pas si c'est possible mais l'indiquer grâce à une mise en forme conditionnelle (MFC) colorer les lignes du tableau s'il y plus d'une fois la présence du groupe dans la colonne E

avec cette formule de MFC : =NB.SI($E$3:$E$9;$E3)>1

Voici comment procéder :

Sélectionne la plage B3 à E9
onglet format puis mise en forme conditionnelle qui ouvre une fenêtre à droite.
La plage à traiter doit être déjà inscrite.
Choisir la couleur (je conseille le rouge vif)
Sous règle de mise en forme développer la liste déroulante et aller tout en bas pour choisir la formule personnalisée est dans le cadre valeur de la formule mettre la formule ci-dessus en respectant bien la position des ($), valider l'installation et faire le test.

Cordialement