Calcul Mention a partir d'une moyenne (libreoffice) [Résolu]

Messages postés
3
Date d'inscription
dimanche 17 novembre 2019
Statut
Membre
Dernière intervention
17 novembre 2019
-
Bonjour,

J'ai un relevé de notes sur lequel je dois trouver une fonction permettant de déterminer la mention de chaque élève selon 2 conditions : sa moyenne et l'existence d'un zéro.

Pour la moyenne voici les conditions : (M=moyenne)
M<6 --> E
6<= M <10 --> D
10<= M <12 --> C
12<= M <15 --> B
15<= M --> A

La deuxième condition veut que si un élève n'a pas de note dans une matière (soit un 0) alors il a la mention "Absent".

Je dois utiliser une imbrication de si pour déterminer la mention. J'ai trouvé cette formule :

=SI($K3=0;“Absent“;SI($I3<6;“E“;SI($I3<10;“D“;SI($I3<12;“C“;SI($I3<15;“B“;“A“)))))

qui me semble être bonne sauf que quand je la valide l'erreur 501 s'affiche dans la cellule. Pire, quand je la tire, j'ai une succession de 0 ou d'erreur #NOM qui se succède…

Je ne comprend pas si l'erreur vient de ma formule ou du formatage des cellules ou d'autre chose…

Je débute sur les tableurs et j'apprécierai beaucoup votre aide, je déteste ne pas comprendre.

Merci pour vos retour !
Afficher la suite 

2 réponses

Messages postés
2235
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
5 décembre 2019
453
0
Merci
Bonjour,

Les guillemets ne sont pas bons, essayer en faisant un copier/coller de la formule rectifiée

=SI($K3=0;"Absent";SI($I3<6;"E";SI($I3<10;"D";SI($I3<12;"C";SI($I3<15;"B";"A")))))



Cordialement
CR2_3244
Messages postés
3
Date d'inscription
dimanche 17 novembre 2019
Statut
Membre
Dernière intervention
17 novembre 2019
-
Ça fonctionne :)
Merci beaucoup !!!!!!

Bonne soirée :)
Commenter la réponse de PapyLuc51
Messages postés
50465
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 décembre 2019
11381
0
Merci
Si je comprends bien, au lieu de répondre et de remercier PapyLuc51, tu t'es contenté de modifier ton texte initial, sans préciser si la formule répond à ton attente ? !
PapyLuc51
Messages postés
2235
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
5 décembre 2019
453 -
Salutations Raymond PENTIER

Il y a peut-être confusion, je ne vois pas de réponse ou de rectification de la part de CR2_3244

J'ai simplement ajouté à ma réponse une image pour montrer que les guillemets sont différents.

Cordialement
CR2_3244
Messages postés
3
Date d'inscription
dimanche 17 novembre 2019
Statut
Membre
Dernière intervention
17 novembre 2019
-
Pas du tout je n'avais pas vu que Papyluc51 m'avait répondu
Commenter la réponse de Raymond PENTIER