Tirage aléatoire dans une (longue) liste [Résolu]

Messages postés
15
Date d'inscription
dimanche 16 juin 2019
Statut
Membre
Dernière intervention
27 novembre 2019
- - Dernière réponse :  eugene - 20 nov. 2019 à 18:28
Bonjour,

J'ai un fichier excel dans lequel une des pages est un répertoire de vocabulaire d'anglais que j'enrichis en fonction de l'avancée des cours de mon fils (509 mots à ce jour)
Une colonne "mots en français" et une colonne "mots anglais".

Je souhaiterais effectuer un tirage au sort d'une dizaine de mots chaque jour dans la liste de mots.
J'ai fait des recherches et la fonction que j'ai trouvée serait du type =CHOISIR(ALEA.ENTRE.BORNES(1;509);B2;B3;B4;B5...)

Je ne me vois pas taper B6;B7 jusqu'à B509 !
J'ai tenté d'écrire B2:B509 mais cela ne fonctionne pas ....
Pourriez-vous me dire s'il existe un moyen de réaliser ma demande ?

Je vous remercie d'ores et déja pour vos éventuelles réponses :)

Configuration: Windows / Chrome 78.0.3904.97
Afficher la suite 

5 réponses

Messages postés
50503
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 décembre 2019
11404
0
Merci
Bonsoir.

Effectivement la fonction CHOISIR n'est vraiment pas appropriée à ce genre de travail.
Il est plus simple d'utiliser la fonction RECHERCHEV.

On commence par insérer une colonne N° en A, puis on définit le nom "plaj" pour la plage de cellules A1:C510
Une fois effectué le tirage aléatoire de 5 numéros entre 1 et 509, utiliser ce numéro pour afficher
soit le mot français =RECHERCHEV(numéro;plaj;2;0)
soit le mot anglais =RECHERCHEV(numéro;plaj;3;0)
Commenter la réponse de Raymond PENTIER
Messages postés
15
Date d'inscription
dimanche 16 juin 2019
Statut
Membre
Dernière intervention
27 novembre 2019
0
Merci
Merci pour votre réponse Raymond ... Malheureusement je n'ai rien compris :(
Je suis désolée :(
Commenter la réponse de Celinette21300
Messages postés
11452
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
8 décembre 2019
1543
0
Merci
Bonjour Celinette

Pour illustrer et compléter la réponse de mon ami Raymond que je salue bien au passage, un petit exemple avec 3 mots tirés au hasard dans une liste de 16 mots, que tu devrais assez facilement pouvoir adapter à ton fichier (explications dans le fichier)
https://mon-partage.fr/f/HTgnh48z/

Si tu n'y arrives pas, fournis un exemple de ton fichier en le postant sur mon-partage.fr, en copiant le lien créé et en revenant le coller ici, je regarderais pour adapter

Cdlmnt
Via
Commenter la réponse de via55
0
Merci
Bonjour,
Je vous envoie par Cjoint un petit exemple réduit à une trentaine de paires de mots Français / Anglais, permettant de sortir à chaque pression de la touche F9 cinq paires de mots.
Cela dit, vous pourriez également voir le site Freelang qui propose des dictionnaires à télécharger, dont le Français / Anglais . Ces dictionnaires comportent un module de "practice lists" de mots tirés au hasard qui correspond, me semble-t-il, à ce que vous cherchez. On peut ajouter des mots à ces dictionnaires, par exemple du vocabulaire professionnel.
En espérant avoir bien compris votre demande.
Cordialement.

https://cjoint.com/c/IKts2Cma4OK

https://www.freelang.com/dictionnaire/index.php
Celinette21300
Messages postés
15
Date d'inscription
dimanche 16 juin 2019
Statut
Membre
Dernière intervention
27 novembre 2019
-
Bonsoir Eugene,

je vous remercie pour votre conseil ...J'abandonne le projet excel (bien trop compliqué pour moi) pour me refugier dans le logiciel que vous m'avez conseillé ...
Merci encore :)
Commenter la réponse de eugene
0
Merci
Bonsoir,
C'était avec plaisir.
La solution Excel que je vous avais proposée n'est pas très compliquée, en fait elle est très proche de votre premier essai tel que décrit dans votre demande initiale, vous y étiez presque arrivée !
Cordialement.
Commenter la réponse de eugene