Formule avec SI et intervalles [Résolu]

Messages postés
11
Date d'inscription
dimanche 3 novembre 2019
Statut
Membre
Dernière intervention
16 novembre 2019
- - Dernière réponse : draydoune
Messages postés
11
Date d'inscription
dimanche 3 novembre 2019
Statut
Membre
Dernière intervention
16 novembre 2019
- 16 nov. 2019 à 17:56
Bonjour,

Je dois dans le tableau joint indiquer un champ calculé sur la différence entre hommes femmes indiquant "négative" si espérance vie femmes < à hommes, faible si différence femmes hommes comprise entre 0 et 5. J'ai fait une formule qui m'indique erreur 508.
Je ne dois pas faire une colonne différence mais tout indiquer dans la même formule.

Merci pour votre aide.

=SI(D2<C2;"négative");SI(ET(D2-C2>=0;D2-C2<5);"FAIBLE;SI(ET(D2-C2>6;D2-C2<10);"importante";SI(ET(D2-C2K3>10);"trèsimportante"";))

https://www.cjoint.com/c/IKqpGyPzzBj
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
27449
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
6 décembre 2019
5716
1
Merci
Bonjour,

Je n'utilise pas OO/LO mais Office Excel donc peut être que les formules ne sont pas gérées de la même façon.

Mais rien qu'à la lecture il y a des anomalies, pas le même nombre de parenthèses ouvrantes que fermantes, les guillemets ne sont pas fermés derrière FAIBLE, 2 guillemets de fermeture derrière très important, est-ce bien le bon champ C2K3 ?, tu traites <5 et > 6 et 5ou 6 ?, <10 et >10 mais quid de =10 ....

Dans une formule de ce type, on peut ne pas tester les 2 bornes, quand on va crescendo, la borne inférieure étant déjà évacuée pas le test précédent.

Sous Excel je ferais :

=SI(D2<C2;"Négative";SI(D2-C2<5;"Faible";SI(D2-C2<10;"Importante";"Très importante"))) 


Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 64055 internautes nous ont dit merci ce mois-ci

draydoune
Messages postés
11
Date d'inscription
dimanche 3 novembre 2019
Statut
Membre
Dernière intervention
16 novembre 2019
-
Merci c'est plus simple et ça marche bien. J'ai aussi modifié la formule d'origine même résultat.

Cordialement.
Commenter la réponse de jee pee
Messages postés
2236
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
6 décembre 2019
453
1
Merci
Bonsoir,

Premier Si retirer la parenthèse après "négative";

Deuxième Si ajouter un guillemet après "FAIBLE" (pourquoi ce mot est en majuscule alors que tous les autres sont en minuscule ?

Quatrième Si la double condition Et n'est pas complète / une espace manque entre les deux mots / un guillemet est en trop après / manque deux guillemets après le ;

terminer la formule en ajoutant 2 parenthèses

=SI(D2<C2;"négative";SI(ET(D2-C2>=0;D2-C2<5);"FAIBLE";SI(ET(D2-C2>6;D2-C2<10);"importante";SI(ET(D2-C2K3>10);"trèsimportante";""))))

Cordialement

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 64055 internautes nous ont dit merci ce mois-ci

draydoune
Messages postés
11
Date d'inscription
dimanche 3 novembre 2019
Statut
Membre
Dernière intervention
16 novembre 2019
-
Merci beaucoup pour cette analyse attentive. C'est bon.
Cordialement.
Commenter la réponse de PapyLuc51