Filtres avances & petite valeurs

Signaler
Messages postés
43
Date d'inscription
dimanche 11 février 2018
Statut
Membre
Dernière intervention
7 décembre 2019
-
serco19
Messages postés
43
Date d'inscription
dimanche 11 février 2018
Statut
Membre
Dernière intervention
7 décembre 2019
-
Bonjours
je viens vers vous, car je bute, avec le filtre avancés ,j'aimerais savoir si c'est possible de mettre dans la ZDC une formule pour extraire uniquement les 3 premières petite valeur d'un même produit.
je vous mets un fichier avec mon exercice

https://www.cjoint.com/c/IKqo5YSlxQ2

merci
Bonjour
Est-il impératif que votre tableau soit structuré exactement comme l'exemple?
Et qu'est-il prévu pour les ex-æquo ?
serco19
Messages postés
43
Date d'inscription
dimanche 11 février 2018
Statut
Membre
Dernière intervention
7 décembre 2019

bonsoir
non la structure n,est pas importante et ce qui concerne les ex-aequo dans le fichiers "réel " avec énormément de produit il n'y as pas d'ex aequo
merci
A quoi correspond la colonne "Prdt" ?
J'imagine qu'il ne faut pas ajouter de colonnes, ni séparer les "0/22.4" des "0/45" ? Et combien y a-t-il de "Produits" ?
Messages postés
11457
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
11 décembre 2019
1546
Bonjour à vous deux

A condition que le tableau initial soit trié sur la colonne Produits de manière que tous les produits identiques se suivent, en I4 mettre la formule
=SIERREUR("<=" & PETITE.VALEUR(DECALER(D1;EQUIV(G4;B2:B10000;0);;NB.SI(B:B;G4));3);"")
et l'étirer vers le bas
Bien sûr si le tableau initial va au delà de la ligne10000, modifier la plage dans la macro

Cdlmnt
Via
Messages postés
43
Date d'inscription
dimanche 11 février 2018
Statut
Membre
Dernière intervention
7 décembre 2019

Re bonjour a vs 2
J e viens de tester la solution préposée par via 55 c'est parfait pour mes besoins
Donc je vous remercie de votre aide
bonne semaine a tous