TABLEAU : la plus ancienne date [Résolu]

Messages postés
30
Date d'inscription
jeudi 10 septembre 2015
Statut
Membre
Dernière intervention
10 novembre 2019
- - Dernière réponse : Richrdk
Messages postés
30
Date d'inscription
jeudi 10 septembre 2015
Statut
Membre
Dernière intervention
10 novembre 2019
- 10 nov. 2019 à 12:02
Salut à tous !

J'ai créé un tableau sur excel avec 2 colonnes : date (colonne B) et catégorie (colonne D).
Je dois trouver la plus ancienne date selon la catégorie.

Ma formule est la suivante :
=SOMMEPROD(MIN((D6:D1000="Carburant")*B6:B1000))
Elle devrait m'afficher 23/09/2019, or le résultat est 30/12/1899 !

Comment puis-je procéder ? Merci pour votre aide précieuse !
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
24666
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 novembre 2019
4886
1
Merci
Bonjour
essayer en matricielle (à entrer avec la touche enter en maintenant les touches ctrl et shit enfoncées:
=MIN(SI(D6:D1000="carburant";B6:B1000))
la formule doit s'afficher automatiquement entre accolades dans la barre e formule si elle est entrée correctement
crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 71512 internautes nous ont dit merci ce mois-ci

Richrdk
Messages postés
30
Date d'inscription
jeudi 10 septembre 2015
Statut
Membre
Dernière intervention
10 novembre 2019
1 -
Merci pour la réponse, sa fonctionne !

En revanche j'aimerais comprendre pourquoi ma formule ne marche pas ! La même formule SOMMEPROD() (citée dans mon 1er post) avec MAX() fonctionne très bien, mais pas avec MIN()...

=SOMMEPROD(MAX((D6:D1000="Carburant")*B6:B1000)) --> affiche bien la date la plus récente
=SOMMEPROD(MIN((D6:D1000="Carburant")*B6:B1000)) --> n'affiche pas la date la plus ancienne (affiche 30/12/1899)
Richrdk
Messages postés
30
Date d'inscription
jeudi 10 septembre 2015
Statut
Membre
Dernière intervention
10 novembre 2019
1 -
Pour information, j'ai trouvé une autre formule intermédiaire non matricielle qui affiche la bonne date :
=MIN.SI.ENS(D6:D1000;B6:B1000;"Carburant")
Commenter la réponse de Vaucluse