.NETFramework,Version=v4.7.1 were not found

Messages postés
11
Date d'inscription
lundi 23 janvier 2017
Statut
Membre
Dernière intervention
9 novembre 2019
- - Dernière réponse : Whismeril
Messages postés
13940
Date d'inscription
mardi 11 mars 2003
Statut
Non membre
Dernière intervention
9 novembre 2019
- 9 nov. 2019 à 23:58


Bonjour,
J'ai un problème je peux pas compiler mon code sur rider donc du C# j'ai ce message d'erreur ".NETFramework,Version=v4.7.1 were not found" j'ai essaye de trouver la solution mais je n'ai pas réussi si quelqu'un peut m'aider a noter que je suis sur Mac
Merci a ceux qui prendront le temps de m'aider
Afficher la suite 

2 réponses

Messages postés
13940
Date d'inscription
mardi 11 mars 2003
Statut
Non membre
Dernière intervention
9 novembre 2019
417
0
Merci
Bonsoir

As tu essayé de télécharger et installer le pack à l'adresse indiquée?
come1706
Messages postés
11
Date d'inscription
lundi 23 janvier 2017
Statut
Membre
Dernière intervention
9 novembre 2019
-
oui mais ca sert a rien ca envoie sur in site pour télécharger un fichier windows et je suis sur mac
Commenter la réponse de Whismeril
Messages postés
13940
Date d'inscription
mardi 11 mars 2003
Statut
Non membre
Dernière intervention
9 novembre 2019
417
0
Merci
Ok, comme ça n'est pas l'adresse Microsoft, j'avais pensé qu'il s'agissait d'un package adapté.

Je ne connais pas cet outils, sur Mac j'ai utilisé Visual Studio Mac.
Et tu comprendras (j'espère) qu'au prix de l'abonnement, je ne vais pas investir "juste" pour essayé de t'aider.

Sais tu quelle framework est valide sur ta config?
Si oui
  • te suffit elle? (c-a-d utilises tu des classes des framework plus récente?)
  • sais tu comment modifier la framework cible de ton projet?


As tu la dernière version de rider?

come1706
Messages postés
11
Date d'inscription
lundi 23 janvier 2017
Statut
Membre
Dernière intervention
9 novembre 2019
-
Oui j'ai essaye
come1706
Messages postés
11
Date d'inscription
lundi 23 janvier 2017
Statut
Membre
Dernière intervention
9 novembre 2019
-
come1706
Messages postés
11
Date d'inscription
lundi 23 janvier 2017
Statut
Membre
Dernière intervention
9 novembre 2019
-


Lorsque que je clique sur mon message d'erreur ca m'ouvre un fichier avec ces deux erreurs la
come1706
Messages postés
11
Date d'inscription
lundi 23 janvier 2017
Statut
Membre
Dernière intervention
9 novembre 2019
-


Lorsque que le clique sur l'ampoule rouge et que j'essaye de corriger l'erreur j'ai ce message la
Whismeril
Messages postés
13940
Date d'inscription
mardi 11 mars 2003
Statut
Non membre
Dernière intervention
9 novembre 2019
417 -
Ben là je ne sais pas.
Mais j'ai pas l'impression qu'il faille aller bidouiller le xml du projet. Plutôt changer la configuration par les menus de Rider (en tout cas dans visual studio c'est comme ça)
Commenter la réponse de Whismeril