Probleme Sources.list [Résolu]

Messages postés
20
Date d'inscription
samedi 3 septembre 2016
Statut
Membre
Dernière intervention
5 novembre 2019
- - Dernière réponse : zipe31
Messages postés
37472
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
22 novembre 2019
- 5 nov. 2019 à 14:08
Bonjour, je travaille sur une machine sous Debian 10 (Buster) et je voudrai installer un package qui n'est disponible que sous Debian 9 (Stretch). J'ai déjà vu quelque part qu'il fallait rajouter des lignes dans /etc/apt/sources.list mais je ne sais plus quoi. Pouvons-vous m'aidez ?


Merci d'avance, Adrien.
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
20
Date d'inscription
samedi 3 septembre 2016
Statut
Membre
Dernière intervention
5 novembre 2019
1
2
Merci
Je me réponds à moi-même. Dans /etc/apt/sources.list il faut rajouter :

deb http://deb.debian.org/debian/ stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

puis dans le répertoire /etc/apt/apt.conf.d/ créer un fichier avec :

APT::Default-Release "buster";


Mais oui tu as raison, on peut facilement mettre la pagaille, mais le package à installer et safe, il n'y a pas de soucis.
Merci pour ta réponse

Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 70225 internautes nous ont dit merci ce mois-ci

zipe31
Messages postés
37472
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
22 novembre 2019
4230 -
Salut,

Merci du retour.
Commenter la réponse de Adiren
1
Merci
Bonjour,
Attention ! un logiciel compilé pour Debian 9 a peu de chances de fonctionner avec Debian 10 : lors de l'installation du vas immanquablement avoir des problèmes de dépendances non satisfaites et si tu tentes de les satisfaire tu risques de casser d'autres dépendances. C'est le meilleur moyen de mettre la pagaille dans un système stable.

Soit tu récupères le code source de ce logiciel et tu l'installes à partir des sources (pas forcément facile si tu n'es pas initié) soit ce logiciel existe sous forme portable et tu l'installes sous cette forme (snap, flatpak). Cette dernière solution serait de loin la meilleure si le logiciel existe sous cette forme.
Commenter la réponse de jns55
Messages postés
20
Date d'inscription
samedi 3 septembre 2016
Statut
Membre
Dernière intervention
5 novembre 2019
1
0
Merci
Je veux installer le package libssl1.0-dev
Commenter la réponse de Adiren