Galaxy S9 ne peux se connecter au hotspot Debian Wi-Fi si sécurisé

Messages postés
34
Date d'inscription
lundi 28 mai 2007
Statut
Membre
Dernière intervention
4 novembre 2019
- - Dernière réponse : mamiemando
Messages postés
29058
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 novembre 2019
- 4 nov. 2019 à 23:00
J'essai de me connecter à un hotspot sécurisé wifi depuis un smartphone Android Galaxy S9.

Mon téléphone m'affiche
incorrect password
.

Le serveur qui fait hotspot m'affiche un log kernel
iwlwifi 0000:00:14.3: Unhandled alg: 0x707


- Ca marche depuis un autre client linux
- Ca marche si je désactive le mot de passe wifi

Le hotspot est sur le kernel :
Linux hotspot 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u1 (2019-09-20) x86_64 GNU/Linux
avec la configuration réseau suivante :


[connection]
id=Hotspot
uuid=ae69d962-c14b-4fbd-a2c4-71dc92a9aaeb
type=wifi
autoconnect=false
permissions=
timestamp=1572639190
[wifi]
mac-address=50:E0:85:83:2B:2E
mac-address-blacklist=
mode=ap
seen-bssids=50:E0:85:83:2B:2E;
ssid=dka
[wifi-security]
key-mgmt=wpa-psk
psk=12345678
[ipv4]
dns-search=
method=shared
[ipv6]
addr-gen-mode=stable-privacy
dns-search=
ip6-privacy=0
method=shared


Le point d'accés wifi est un Lenovo X1 Carbon Gen 7 (2019) tournant sur Debian Buster.

Il utilise une carte Wi-FI (Model: INTEL® WIRELESS-AC 9560 (https://www.intel.com/content/www/us/en/products/wireless/wireless-products/dual-band-wireless-ac-9560.html?wapkw=ac+9560%29) pour crée le réseau hot spot et utilise une connexion internet à travers le modem WWAN (Model: Fibocom L850-GL (http://www.fibocom.com/prod_view.aspx?typeid=31&id=185&fid=t3%3A31%3A3%29, voirTechnicalSpecification-L850GL.pdf (http://www.fibocom.com/Private/ProductFiles/77bb8fb9ddca4fbbafcc2b2157c1ad40.pdf) pour plus de détails) ainsi qu'une carte sim 4G nano.

En devinant, je dirait que
Unhandled alg 
suggére un cipher non supporté.

C'est un problème de sécurité qui doit etre réparé, cela peux engendrer des cout si une personne non voulu se connecte au réseau. J'espère que quelqu'un ici peux m'aider.

Si vous avez des idées pour remettre la sécurité du réseau et que je peux rejoindre depuis mon téléphone Android.

Bien à vous,

Configuration: Linux / Chrome 78.0.3904.87
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
29058
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 novembre 2019
6694
1
Merci
Bonjour,

D'après cette discussion, il semblerait qu'utiliser une autre version de noyau (5.4 mais pas 5.3) pourrait résoudre ton problème.

Regarde les versions de
linux-image-*-amd64
dans ton gestionnaire de paquets, puis dans grub, redémarre sur le noyau approprié.

Bonne chance

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 71125 internautes nous ont dit merci ce mois-ci

kopax
Messages postés
34
Date d'inscription
lundi 28 mai 2007
Statut
Membre
Dernière intervention
4 novembre 2019
4 -
Bonjour et merci pour votre réponse,

j'ai déjà tenté une mise à jour mais cela posait problème sur mon systeme au niveau des dépendenaces, je dois donc attendre que le Kernel 5.4 soit dans la branche stable des repository Debian.
Savez-vous quand est-ce que cela devrait intervenir ?

Cordialement,
mamiemando
Messages postés
29058
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 novembre 2019
6694 -
Non, aucune idée. Dans l'intervalle, tu peux commencer par régler tes problèmes de dépendances, ça facilitera la mise à jour une fois que ce noyau sera empaqueté sous debian.

Autre solution, tu récupères les sources de noyaux et tu les recompiles. Mais attention c'est long et fastidieux. Si tu veux tenter l'aventure, tu peux repartir de ce message (à partir de l'étape 5).
Commenter la réponse de mamiemando