Identifier certains jours au cours d'une année [Résolu]

Messages postés
13
Date d'inscription
mercredi 6 février 2019
Statut
Membre
Dernière intervention
8 novembre 2019
-
Bonjour,

Je travaille actuellement sur plusieurs années.
J'ai une sélection de quelques jours spéciaux.
J'aimerais avoir une colonne qui m'affiche 0 ou 1 si le jour de la ligne est spécial ou pas.
Facile à faire pour une année, car on peut faire un si(nb.si(matricedesjoursspéciaux;jourdelaligne)>0;1;0).
Sauf que je travaille avec plusieurs années et donc cette méthode ne fonctionne pas.
J'ai essayé de faire deux colonnes pour les jours spéciaux, une avec le numéro du jour et une avec le mois, sauf que je n'arrive pas écrire la fonction. Cette fonction dirait, si il existe un jour spécial pour lequel jour=jourdelaligne et mois=moisdelaligne alors 1 ou 0.

Une solution ?
Voici le document : https://www.cjoint.com/c/IJFrvNC2TqD

Merci d'avance !
Afficher la suite 

3 réponses

Messages postés
59530
Date d'inscription
mardi 8 janvier 2008
Statut
Modérateur
Dernière intervention
13 novembre 2019
4958
0
Merci
Bonjour,

Pour mettre à disposition un fichier, tu peux utiliser des sites comme cjoint. Veille à anonymiser le contenu pour ta sécurité et celles des personnes dont les données pourraient être incluses.
Sharsus
Messages postés
13
Date d'inscription
mercredi 6 février 2019
Statut
Membre
Dernière intervention
8 novembre 2019
-
Merci pour la réponse, j'ai mis à jour la publication.
Commenter la réponse de Chris 94
Messages postés
247
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
12 novembre 2019
9
0
Merci
Bonjour,

Essaie de mettre tes jours spéciaux sous forme de date réelle (jj/mm/aaaa), fais une colonne pour chaque année voulue et ensuite dans ta formule si(nb.si(matricedesjoursspéciaux;jourdelaligne)>0;1;0) choisis ta matricedesjoursspéciaux comme l'ensemble des années voulues.

Cordialement
Sharsus
Messages postés
13
Date d'inscription
mercredi 6 février 2019
Statut
Membre
Dernière intervention
8 novembre 2019
-
Bonjour,

Merci pour la réponse. Le problème est que cet exemple est ici d'un gigantesque Excel. La colonne des années est accompagnées de plein d'autres colonnes de calcul et j'aimerais éviter de rajouter des colonnes/feuilles.
Mais je retiens la solution s'il n'y a rien d'autre de faisable.
ALS35
Messages postés
247
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
12 novembre 2019
9 -
Re,

Tu peux mettre l'ensemble de tes jours spéciaux sur une feuille distincte.

Tes jours spéciaux sont-ils toujours les mêmes d'une année sur l'autre ?

Cordialement
Sharsus
Messages postés
13
Date d'inscription
mercredi 6 février 2019
Statut
Membre
Dernière intervention
8 novembre 2019
-
Oui mais il y a toujours le problème d'encombrement

et oui
ALS35
Messages postés
247
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
12 novembre 2019
9 -
Re,

Tu peux essayer en C3
=NB.SI.ENS($G$4:$G$35;JOUR(B3);$H$4:$H$35;TEXTE(B3;"mmmm"))

Cordialement
Sharsus
Messages postés
13
Date d'inscription
mercredi 6 février 2019
Statut
Membre
Dernière intervention
8 novembre 2019
-
C'est exactement ce qu'il me fallait merci beaucoup !
Commenter la réponse de ALS35
Messages postés
23064
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2019
5749
0
Merci
Bonjour,

met ta colonne G en format Texte et saisis tes jours sous cette forme :
10/01
14/02
03/03

En C3 :
=NB.SI(G:G;TEXTE(B3;"jj/mm")) 


ou avec la liste sur une autre feuille :
=NB.SI(Feuil2!$A$2:$A$33;TEXTE(B3;"jj/mm"))

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Sharsus
Messages postés
13
Date d'inscription
mercredi 6 février 2019
Statut
Membre
Dernière intervention
8 novembre 2019
-
Merci, je suppose que cela fonctionne également !
eriiic
Messages postés
23064
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2019
5749 -
Je suppose qu'en testant tu auras la réponse.
Commenter la réponse de eriiic