Trois formules d'après trois cas (heures) [Résolu]

Messages postés
597
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
3 novembre 2019
- - Dernière réponse : Nai
Messages postés
597
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
3 novembre 2019
- 3 nov. 2019 à 16:20
Bonjour toutes et tous ! :)
Je voudrais calculer des heures mais selon plusieurs schémas différents.
J'ai, pour le matin et l'après-midi, des horaires d'embauche et de débauche, et aussi des heures "supplémentaires".
Ainsi, dans le fichier joint, les colonnes "Matin", "Après-midi" et "Autres" ne sont pas toujours renseignées.

- Si les colonnes "Matin" et/ou "Après-midi" sont remplies (contiennent des données), alors 7 heures sont déduites de la journée (ligne) concernée (dans le solde).

- Si les colonnes "Matin" et/ou "Après-midi" ne sont pas remplies (ne contiennent pas de données), alors ne rien déduire de la journée (ligne) concernée. Comme pour les weekends par exemple.

- Si les colonnes "Autres" sont remplies (contiennent des données), ET que les colonnes "Matin" et/ou "Après-midi" ne sont pas remplies, alors ne rien déduire de la journée (ligne) concernée. Ce sont des heures supplémentaires (comme des heures travaillées un weekend ou un jour férié).

- Si aucune colonne n'est remplie, alors ne rien déduire.

La colonne "Nb d'heures effectuées" ne me pose pas de problème.
En revanche, la colonne "Heures à rattraper ou récupérer" me pose problème étant donné les différents cas possible.
Est-ce qu'il est possible d'entrer trois formules différentes selon les cas ?

Merci d'avance pour votre aide !

Lien du fichier : https://www.cjoint.com/c/IJFkXiTIPP8
Configuration: Windows 8.1 / Excel 2010

Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
11329
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 novembre 2019
1501
1
Merci
Au temps pour moi !
Et si tu mets cela comme formule :
=SI(SOMME(F8:I8)=0;K8-J8;L8-$J$2)

elle devrait fonctionner dans tous les cas, ou alors il y a encore quelque chose que je n'ai pas compris !

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 71538 internautes nous ont dit merci ce mois-ci

Nai
Messages postés
597
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
3 novembre 2019
45 -
C'est exactement ça ! Merci ! :)
Commenter la réponse de via55
Messages postés
11329
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 novembre 2019
1501
0
Merci
Bonjour Nai

Je ne comprends pas tes 3 cas
Pour moi d'après ce que tu dis ils ne se résument qu'à un seul : on déduit 7 h lorsque ou matin ou après-midi est rempli

Peux tu donner plus d'exemples et des exemples chiffrés ?

Cdlmnt
Via



Nai
Messages postés
597
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
3 novembre 2019
45 -
Merci pour ta réponse ! :)
Dans la feuille de Janvier : https://www.cjoint.com/c/IKct4wnIPgj
Du mardi 1er au 3, tout va bien. Mais le 4 (avec des données en matin, après-midi et autres), je n'obtiens pas le bon résultat si j'applique la même formule...
Je ne trouve plus les trois cas auxquels je pensais, mais deux ^^
Il est possible de la formule de départ ne soit pas bonne :/

Merci de ton aide !
Commenter la réponse de via55
Messages postés
11329
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 novembre 2019
1501
0
Merci
Quel serait le bon résultat ?
Les 2 heures autres sont à considérer comme de vraies heures supp ?
Dans ce cas il manque dans ton tableau une colonne pour les heures supplémentaires
Nai
Messages postés
597
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
3 novembre 2019
45 -
Le résultat affiché est le bon, mais il ne s'agit pas de la même formule.
Mardi, j'ai :
=SI(SOMME(F8:I8)=0;0;L8-$J$2)+(K8-J8)

Et jeudi :
=SI(SOMME(F11:I11)=0;0;L11-$J$2)
Commenter la réponse de via55