Problème format de cellule avec la fonction SI [Résolu]

- - Dernière réponse : PapyLuc51
Messages postés
2162
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
31 octobre 2019
- 24 oct. 2019 à 21:12
Bonjour,

Après avoir effectué de nombreuses recherches, impossible de trouver une solution à mon problème.

Le voici : sur mon fichier Excel, j'utilise, dans ma cellule, une fonction SI que j'ai moi même bricolé.

La voici : =SI(A42="Location 1 taux horaire A";10/1,2;""&SI(A42="Location 1 taux horaire B";8/1,2;""&SI(A42="Location 1 taux horaire C";5;"")))).

La fonction en elle même fonctionne très bien. Le problème vient en fait du format de la cellule avec cette fonction. En effet, je souhaite réduire le nombre de décimales qui apparaissent dans la cellule, quand la condition est réunie et donc qu'un résultat numérique apparaît.

Pour la première condition de la formule (=SI(A42="Location 1 taux horaire A";10/1,2;""), aucun problème, il m'est possible de réduire le nombre de décimales du résultat de 10/1,20. En revanche pour toutes les autres conditions suivantes de la formule et donc notamment SI(A42="Location 1 taux horaire B";8/1,2;"", où le résultat donne 6,666666666666667, impossible cette fois de réduire le nombre de décimales.

J'ai bien entendu essayé l'ensemble des possibilités sur le format de cellule, mais impossible de trouver une solution.

Si vous pouviez m'éclairer,

Merci d'avance
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
2162
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
31 octobre 2019
435
1
Merci
Bonsoir

La formule avec $ n'est pas bonne

il faut l'écrire :

=SI(A42="Location 1 taux horaire A";10/1,2;SI(A42="Location 1 taux horaire B";8/1,2;SI(A42="Location 1 taux horaire C";5;"")))

Cordialement

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 69531 internautes nous ont dit merci ce mois-ci

Bonsoir,

Merci pour votre retour.

Toutefois il n'y a pas de $ dans ma formule.

De plus, je ne vois pas la différence entre votre proposition et ma formule initiale hormis le fait qu'il n'y est plus les "" qui me servent à laisser la case vide lorsque la condition n'est pas remplie.

De ce fait je n'ai pas encore résolu le problème.

Cordialement
PapyLuc51
Messages postés
2162
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
31 octobre 2019
435 > Tanner -
effectivement, désolé de cette coquille dans la dactylographie de ma réponse, pas le $ mais le & mais bon la formule corrigée était bonne,

Cordialement
Bonsoir,

ALS35 vient de m'apporter la réponse et je réalise donc qu'en fait, après relecture de la formule proposée, vous alliez dans le même sens que lui et que votre réponse était donc également la solution à mon problème.

Encore merci.

Cordialement
Commenter la réponse de PapyLuc51
1
Merci
Bonjour,
Si vous n'êtes confronté qu'à ces trois possibilités il vaut mieux faire un plan de travail et utiliser la fonction recherche :

Tableau pour fonction RECHERCHE références B12:C14 :

Location 1 taux horaire A 8,333333333 (=10/1,2)
Location 1 taux horaire B 6,666666667 (=8/1,2)
Location taux horaire C 5

Et dans votre tableau utiliser la fonction : =SI(B17="";"";RECHERCHE(B17;$B$12:$C$14)) et ensuite réduire les décimales.
Bien cordialement,

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 69531 internautes nous ont dit merci ce mois-ci

Bonsoir,

Merci pour votre retour.

En fait la vraie formule contient une quinzaine de conditions. Celle que j'ai posté, avec les 3 conditions, n'est qu'un extrait de la véritable formule.

J'ai testé plusieurs fois votre proposition avec la fonction RECHERCHE et la fonction SI. Le problème reste cependant le même, à savoir que dès la deuxième condition de la fonction SI, il est impossible de changer l'affichage des décimales. J'ai fais également les tests avec seulement la fonction RECHERCHE mais, pour l'instant, cela ne me convient toujours pas car j'ai besoin de la fonction SI afin de laisser la cellule vide lorsque les conditions ne sont pas remplies.

De ce fait je n'ai pas encore résolu le problème.

Cordialement
> Tanner -
Bonsoir, si votre fichier ne comporte pas de données confidentielles vous pouvez peut-être le joindre pour le tester?
Bonne soirée,
> Magie13 -
Bonsoir,

ALS35 vient de m'apporter la réponse.

Merci pour votre temps et votre rapidité.

Cordialement
ALS35
Messages postés
232
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
1 novembre 2019
8 -
Bonjour,

Le problème vient des ""& qui sont en trop dans ta formule.
Par rapport à ton exemple essaie
=SI(A42="Location 1 taux horaire A";10/1,2;SI(A42="Location 1 taux horaire B";8/1,2;SI(A42="Location 1 taux horaire C";5;"")))

Cordialement
> ALS35
Messages postés
232
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
1 novembre 2019
-
Bonsoir,

Merci pour votre retour.

Je viens d'effectuer les modifications préconisées sur l'ensemble de ma formule et effectivement, cela fonctionne !

Quel bonheur. L'erreur est tellement bête en plus...

Encore merci à vous et aux autres pour vos retours si rapides.

Cordialement
Commenter la réponse de Magie13