Fonction CONCATENER + Type de Nombre

Messages postés
11
Date d'inscription
mardi 21 mars 2017
Statut
Membre
Dernière intervention
28 octobre 2019
- - Dernière réponse : damien087
Messages postés
11
Date d'inscription
mardi 21 mars 2017
Statut
Membre
Dernière intervention
28 octobre 2019
- 28 oct. 2019 à 14:31
Bonjour,

J'ai deux cellules. Une qui affiche le mois, et une autre qui affiche l'année.
A1 affiche 01
A2 affiche 2019

Lorsque j'essaye :
Option 1 : =CONTANENER(A1;"_";A2) --> Excel affiche 1_2019.
Option 2 : =A1 & "_" & A2 --> Excel affiche 1_2019.
Option 3 : =TEXTE(A1;00) & "_" & TEXTE(A2;0000) --> Excel affiche 1_2019

Or je souhaite conserver le 0. J'imagine qu'il y a quelque chose à faire dans le type de "Nombre" mais je ne sais pas quoi.
Au format "Texte" il m'affiche la formule.

Pouvez m'aider à afficher ce "0" svp ?
NB: Il faudra que celui-ci disparaisse quand j'arriverai sur les mois 10, 11, 12.

Bonne soirée.
Damien.


Configuration: Windows / Chrome 77.0.3865.120
Afficher la suite 

3 réponses

Messages postés
16979
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 novembre 2019
3670
0
Merci
Bonjour,

Essaye comme cela

=TEXTE(A1;"00" )& "_" & A2
damien087
Messages postés
11
Date d'inscription
mardi 21 mars 2017
Statut
Membre
Dernière intervention
28 octobre 2019
-
Bonjour Mike-31.

Merci pour ton retour.
J'ai testé ta méthode. Nickel. Merci.

A+
Damien
Commenter la réponse de Mike-31
Messages postés
2176
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
13 novembre 2019
439
0
Merci
Bonsoir

autre version concaténation

=SI(A1<=9;"0"&A1&"_"&A2;A1&"_"&A2)

Cordialement
Commenter la réponse de PapyLuc51
Messages postés
1726
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
12 novembre 2019
448
0
Merci
Bonjour
Une autre proposition
=DATE(A2;A1;"1") 

avec un format de date MM/AAAA
Commenter la réponse de yclik