=SOMME.SI.ENS [Résolu]

Messages postés
263
Date d'inscription
lundi 12 octobre 2009
Statut
Membre
Dernière intervention
23 octobre 2019
- - Dernière réponse : nathan01983
Messages postés
263
Date d'inscription
lundi 12 octobre 2009
Statut
Membre
Dernière intervention
23 octobre 2019
- 21 oct. 2019 à 22:46
Bonjour

Je vous présente ma formule, présente dans la cellule C10

=SOMME.SI.ENS('S1'!G4:G17;'S1'!D4:D17;">="&C5;'S1'!D4:D17;"<="&C6)

Ce que j'aimerai pouvoir faire c'est écrire dans C9, les texte suivant S1 ou S2 ou S3 et que dans ma formule écrite un peu plus haut je puisse remplacer 'S1' par la valeur de la cellule C9.

Est ce possible ? je vous remercie d'avance :)
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
11328
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
12 novembre 2019
1500
1
Merci
Re,

Même procédé que dans ton autre post, il faut utiliser la fonction INDIRECT
=SOMME.SI.ENS(INDIRECT("'" & C9 & "'!G4:G17");INDIRECT("'" & C9 & "'!D4:D17");">="&C5;INDIRECT("'" & C9 & "'!D4:D17");"<="&C6)

Cdlmnt
Via

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 70865 internautes nous ont dit merci ce mois-ci

nathan01983
Messages postés
263
Date d'inscription
lundi 12 octobre 2009
Statut
Membre
Dernière intervention
23 octobre 2019
6 -
Parfait ! Et merci BCP !!!

Je rectifie juste par rapport à ma demande mais

=SOMME.SI.ENS(INDIRECT("'" & $B$10 & "'!$G$4:$G$17");INDIRECT("'" & $B$10 & "'!$D$4:$D$17");">="&C5;INDIRECT("'" & $B$10 & "'!$D$4:$D$17");"<="&C6)
Commenter la réponse de via55