Comment copier/coller valeurs IntituléLien et Lien Hypertexte issu d'une formule

Messages postés
138
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
14 novembre 2019
- - Dernière réponse : traderpierre
Messages postés
138
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
14 novembre 2019
- 28 oct. 2019 à 23:27
Bonjour,

Comment copier/collage spécial Valeurs Intitulé d'un lien et Lien Hypertexte adossé issu d'une formule afin qu'il conserve son intitulé de lien et son lien.

Je m'explique :
Colonne N "intitulée : N° de commande"
J'ai cette valeur : 20720879501025939

Colonne O, "intitulée lien commande"
J'ai cette formule pour construire et éditer le lien :
=SI(N2<>"";LIEN_HYPERTEXTE("https://biz.alibaba.com/ta/detail.htm?orderId="&N2&"&tracelog=from_orderlist_dropdown";"Voir la Commande");"")

Maintenant je souhaite copier la colonne O et faire un collage spécial "Valeurs" à sa place pour ne plus avoir les formules.

Le problème c'est qu'Excel copie uniquement l'intitulé des liens mais pas les liens
Comment procéder pour que les intitulés et les liens soient conservés dans le collages spécial Valeurs ????

Merci pour votre aide
Afficher la suite 

2 réponses

Messages postés
50337
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
11183
0
Merci
Le collage spécial a justement pour finalité de remplacer les formules par leur résultat.
Donc le lien hypertexte n'est plus une formule et ne sert plus à rien.
traderpierre
Messages postés
138
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
14 novembre 2019
-
Merci pour l'info,
Donc c'est pas possible, dans ce cas je vais laisser le texte du lien sans son intitulé et lorsque je importerai dans Access, je déclarerai ce champ au format Lien Hypertexte

Je viens de corriger ma formule ci-dessous en supprimant l'intitulé du lien

=SI(N2<>"";LIEN_HYPERTEXTE("https://biz.alibaba.com/ta/detail.htm?orderId="&N2&"&tracelog=from_orderlist_dropdown");"")
Commenter la réponse de Raymond PENTIER
Messages postés
138
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
14 novembre 2019
0
Merci
Bonsoir,
Je m'explique :
Dans une cellule j'ai développé une formule qui va chercher un lien d'une autre cellule et une partie de sont intitulé :
=SI(ET(R2<>"";GAUCHE(A2;8)="Commande");LIEN_HYPERTEXTE(AdrHyperlien( A2);DROITE(A2;NBCAR(A2)-CHERCHE("/";A2;1)));"")

AdrHyperlien(A2) est la fonction visual basic développée pour récupérer le lien de la celluleA2

DROITE(A2;NBCAR(A2)-CHERCHE("/";A2;1)) me permet de récupérer la chaîne de texte située derrière le /
Cette chaîne constitue l'intitulé du lien

Et la fonction LIEN_HYPERTEXTE() regroupe le lien et son intitulé.

Tout fonctionne correctement jusque là

Maintenant je souhaite copier coller cette cellule pour supprimer la formule tout en conservant uniquement l'intitulé adossé à son lien.

Comment procéder :
Si je fais un collage de valeur, je perd le lien !!!
si je fais un collage normale, j'ai la formule !!!

Comment procéder pour éliminer la formule tout en conservant intitulé et lien ????

Merci par avance
Commenter la réponse de traderpierre