Windows 10 : BOOTMGR IS MISSING [iMac, rEFInd, multiboot Windows, UBuntu, macOS] [Résolu]

Messages postés
8
Date d'inscription
samedi 19 octobre 2019
Statut
Membre
Dernière intervention
26 octobre 2019
- - Dernière réponse : Edawards
Messages postés
16341
Date d'inscription
dimanche 25 juillet 2010
Statut
Membre
Dernière intervention
12 novembre 2019
- 26 oct. 2019 à 16:32
Bonjour/bonsoir,

J'ai récemment prit la décision d'installer en mutliboot sur mon iMac. L'installation se passe avec quelques soucis liés au driver de la carte mais ils sont rapidement réglés. Hors avant cela j'avais déjà installé Windows 10 via l'assistant BootCamp. Lorsque je démarre mon iMac et tente de lancer Windows depuis rEFInd le message suivant s'affiche :

BOOTMGR IS MISSING
Press CTRL + ALT + DEL to restart.

En passant par "l'EFI" (je présume, je n'en connais pas le réel nom) de l'iMac par lequel avant l'installation de rEFInd je passais pour démarrer sous Windows le même soucis se pose.

Une bonne ou une mauvaise idée mais venu à l'idée, réinstaller Windows 10 sur la partition de mon disque avec une clé USB sur laquelle j'ai flashé la version 1803 de Windows depuis sur mon autre ordinateur. Mais lors de ma tentative désespérée de réinstaller Windows, lorsque je choisis la partition (Ici disk4 quelque chose du genre) l'installateur me dit que les tables de partition sont en MBR et que pour installer Windows 10 il me faudrait une partition en GPT.

Malgré mes recherches je n'ai su trouvé le moyen de remédier à ce problème. Je ne peux me permettre de perdre les données du système, en revanche celle de Ubuntu n'ont pas trop d'importance.

Quelle solution puis-je utilisé afin de récupérer la possibilité de faire tourner les trois OS en multiboot ?
Afficher la suite 

3 réponses

Messages postés
16341
Date d'inscription
dimanche 25 juillet 2010
Statut
Membre
Dernière intervention
12 novembre 2019
1078
0
Merci
Bonjour,
Voir ici peut-être une réponse liée à votre problème :

https://forums.macg.co/threads/probleme-triple-boot-sur-imac.1320233/
Slaz
Messages postés
8
Date d'inscription
samedi 19 octobre 2019
Statut
Membre
Dernière intervention
26 octobre 2019
-
Malheureusement pour moi ceci n'est pas la solution à mon soucis. J'ai correctement installé Ubuntu et GRUB ne m'a jamais posé de soucis.

Ce n'est pas tant un soucis lié à rEFInd il me semble mais plutôt un soucis lié au partitionnement. Ubuntu démarre correctement, macOS aussi mais Windows ne peut être réinstaller car la table de partitions est en MBR. Cependant même l'outil de réparation de Windows lancé depuis un clé USB ne donne rien, impossible de faire quoi que ce soit avec cet outil.

Mais formaté mon disque dur en GPT pourrait me faire perdre toutes mes données (celles de macOS étant primordiales), ce qui, sans mentir, serait fort désagréable.
Salut,

Je ne vois pas comment Refind pourrait fonctionner si le disque est au format mbr. Refind s'installe sur un disque gpt. Ton message d'erreur fait penser à un mbr pour W7 (et non W10 qui propose un message different) qui cherche désespérément ses fichiers de démarrage.

Si ubuntu fonctionne, donne le résultat de

sudo fdisk -l

Ou mieux, un rapport boot-info : https://doc.ubuntu-fr.org/tutoriel/boot-info#installation
Slaz
Messages postés
8
Date d'inscription
samedi 19 octobre 2019
Statut
Membre
Dernière intervention
26 octobre 2019
-
Voici le résultat de la commande "sudo fdisk -l" :



Pour le rapport boot-info je le ferais le plus vite possible mais je suis occupé en parallèle. Je ferais au plus vite !

ps: En regardant le screen un peu mieux, j'ai bien l'impression que mon disque est en GPT mais alors la raison pour laquelle Windows ne veut pas s'installer sur mon disque, elle m'est inconnue. :/
Commenter la réponse de Edawards
Messages postés
16341
Date d'inscription
dimanche 25 juillet 2010
Statut
Membre
Dernière intervention
12 novembre 2019
1078
0
Merci
Bonjour,
Lire bien ceci sur l'ordre de Boot des versions à installer :


https://forum.ubuntu-fr.org/viewtopic.php?id=2034753


Si la clé de 64 Go est celle qui doit installer W10, il vaudrait mieux la formater en fat32 plutôt qu'en NTFS. Car là, elle ne doit booter qu'en mode legacy. Après, gpt serait mieux, en effet.

Quant à ton Ubuntu installé sur une partition au format Windows, je dois t'avouer que je ne sais pas gérer cela, car d'après les tutos consultés, on crée des partitions ext4, même sur Mac.
Slaz
Messages postés
8
Date d'inscription
samedi 19 octobre 2019
Statut
Membre
Dernière intervention
26 octobre 2019
-
L'installation sur la clé est possible effectivement, mais ce que je cherche à faire c'est d'installer W10 sur la partition sda4 mais lors de l'installation j'ai justement ce fameux souci m'affichant que W10 ne peut-être installer sur un disque dont les tables de partitions sont en MBR pour EFI alors que si je ne m'abuse mon disque est bel et bien en GPT. :/
Fais une capture d'écran du message d'erreur et des partitions qui s'affichent. Je ne comprends pas, moi non plus, pourquoi tu as ce message.
Slaz
Messages postés
8
Date d'inscription
samedi 19 octobre 2019
Statut
Membre
Dernière intervention
26 octobre 2019
-


Voici le message d'erreur que l'on m'affiche lors de ma tentative d'installer Windows sur la partition (le même message s'affiche pour toutes les partitions).
Re,

J'aurais bien aimé voir les partitions en dessous pour comparer avec fdisk. Fais shift gauche et F10, ce qui ouvre une invite de commandes et fais une photo de :

diskpart
list disk
list vol
sel disk 0
list part
exit
Commenter la réponse de Edawards
Messages postés
8
Date d'inscription
samedi 19 octobre 2019
Statut
Membre
Dernière intervention
26 octobre 2019
0
Merci
Problème résolu, j'ai simplement reformater ma partition, sda4 en l'occurrence, au format NTFS depuis Ubuntu (même si j'avais déjà tenter cette solution avant). J'ai ensuite redémarrer mon ordi en gardant la touche "ALT" enfoncé, je suis donc arrivé dans le menu dans lequel l'on sélectionne le disque sur lequel démarré, de là j'ai donc démarré sur ma clé USB, reformater la partition depuis l'installateur et à l'inverse de mes tentatives précédentes, aucun souci MBR ou GPT.

Je pense que le souci était le fait de démarrer ma clé USB depuis rEFInd et non depuis le "menu" de base de l'iMac.

Merci à ceux qui m'on aidé. ;)
Edawards
Messages postés
16341
Date d'inscription
dimanche 25 juillet 2010
Statut
Membre
Dernière intervention
12 novembre 2019
1078 -
Bonjour,
Content pour vous et merci du retour cela va en aider plus d'un rencontrant le même problème que vous sur le forum.
Dans le lien que j'ai mis au départ, ils le mentionnent bien pas besoin avec Ubuntu de rEFInd pour démarrer sur une clé ou autre.

Bonne continuation et bonne journée aussi.
Commenter la réponse de Slaz