Nombre d’occurrence dans des cellules filtrées [Résolu]

- - Dernière réponse :  mlg35 - 18 oct. 2019 à 11:27
Bonjour à tous,

Je n'arrive pas à résoudre mon problème qui je pense est relativement simple :
A1 : A, B, C
A2 : A, B, D, E
A3 : B, C, D, E
A4 : A, E

A, B, C, D et E représentent des expressions de mots (par exemple "j'aime excel")

B1 : Cheval
B2 : Chien
B3 : Chat
B4 : Cheval

Je filtre ma feuille sur la colonne B avec Cheval.

Je cherche au final à calculer combien de fois A, B, C, D et E s'affichent lorsque j'applique un filtre (j'arrive à trouver les valeurs sans le filtre avec la fonction "=NB.SI(A1:A4;"A")")

Dans l'exemple je devrais trouver
A =>2
B =>1
C =>1
D =>0
E =>1

Merci !
Afficher la suite 

1 réponse

Messages postés
24660
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 novembre 2019
4881
0
Merci
Bonjour

si c'est pour compter le nombre de lignes visibles une fois filtrées, vous pouvez
créer une colonne hors champ avec 1 pour chaque ligne qui contient un texte
entrer en haut de la colonne cette formule:
=SOUS.TOTAL(9;champ ,des 1)

par contre sans filtrer vous pouvez trouver combien de cellule contiennent un mot inclus dans un texte
par exemple de>A2àA100 les textes en B2 inscrivez cheval (ou autre)
en C2 la formule:
=NB.SI(A2:A100;"*"&B2&"*")
vous donnera le nombre de textes qui contiennent le mot inscrit en B2
crdlmnt
Bonjour Vaucluse,

Merci pour ce retour mais ce n'est pas ce que je recherche :
- je filtre sur la colonne B mais je veux compter les occurrences dans A qui correspondent au filtre de B
Vaucluse
Messages postés
24660
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 novembre 2019
4881 -
Alors toujours sans filtre, si ça peut vous aider

NB.SI.ENS(B:B;valeur à filtrer;A:A;valeur à compter)

vous pouvez rajouter des conditions

crdlmnt
Merci beaucoup !! C'est exactement ce dont j'avais besoin !
Commenter la réponse de Vaucluse