Somme à 3 conditions sur période [Résolu]

Messages postés
142
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 novembre 2019
- - Dernière réponse : PYGOS69
Messages postés
142
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 novembre 2019
- 17 oct. 2019 à 16:41
Bonjour,

Nous souhaitons rapprocher des données de 2 fichiers en utilisant plusieurs clés d'entrées : un numéro d'agent ainsi que des dates.
La problématique étant que pour une même période dans un fichier nous n'avons qu'une ligne et que dans le deuxième fichier, la période peut être scindée en plusieurs lignes.

1er fichier : (Colonne de A à K) > formule en K

A B C D E F G H I J
2 NUM NOM PRENOM DEB P1 FIN P2 B TT Montant récupéré
3 10 TOTO X X 27/08/2018 M 31/08/2018 S 10 1110 633,05
4 10 TOTO X X 03/09/2018 M 07/09/2018 S 10 1110 728,01
5
6 10 TOTO X X 27/08/2018 M 07/09/2018 S 10 1110 0

K3=SOMMEPROD(([Fichier2.xlsx]Feuil1!$A$3:$A$50000=$B3)*([Fichier2.xlsx]Feuil1!$D$3:$D$50000=$E3)*([Fichier2.xlsx]Feuil1!$E$3:$E$50000=$G3)*([Fichier2.xlsx]Feuil1!$J$3:$J$50000))

K4=SOMMEPROD(([Fichier2.xlsx]Feuil1!$A$3:$A$50000=$B4)*([Fichier2.xlsx]Feuil1!$D$3:$D$50000=$E4)*([Fichier2.xlsx]Feuil1!$E$3:$E$50000=$G4)*([Fichier2.xlsx]Feuil1!$J$3:$J$50000))

K6=SOMMEPROD(([Fichier2.xlsx]Feuil1!$A$3:$A$50000=$B6)*([Fichier2.xlsx]Feuil1!$D$3:$D$50000=$E6)*([Fichier2.xlsx]Feuil1!$E$3:$E$50000=$G6)*([Fichier2.xlsx]Feuil1!$J$3:$J$50000)) je devrais avoir 1361.06 (633.05+728.01au lieu de 0 .

Merci d'avance pour votre aide !

Cordialement,


Configuration: Windows / Internet Explorer 11.0
Afficher la suite 

1 réponse

Messages postés
24664
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 novembre 2019
4881
0
Merci
Bonjour
pas très claire comme question et surtout, sans voir les fichiers, difficile de pouvoir répondre!
les formules sont correctes (dans leur écriture)
Vérifiez que les libellés de référence soient bien écrits de la même façon(blancs en trop, orthographe, accents etc...)


PYGOS69
Messages postés
142
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
6 novembre 2019
2 -
Merci Vaucluse, j'ai revu ma question avec les données des 2 fichiers....Merci d'avance !

Quand la période est éclatée sur 2 lignes dans le fichier source, sommeprod ne fonctionne pas....
Commenter la réponse de Vaucluse