Formules Condition combinées avec la gestion de la cellule vide. [Résolu]

Messages postés
3
Date d'inscription
jeudi 10 octobre 2019
Statut
Membre
Dernière intervention
10 octobre 2019
- - Dernière réponse : Vaucluse
Messages postés
24613
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2019
- 11 oct. 2019 à 07:06
Bonjour,

Je dois calculer l'age d'enfants en fonction de leur date de naissance et indiquer "new born" lorsqu'ils ont moins d'un mois.
J'ai donc appliqué la formule :
=SI(ET(DATEDIF(B11;AUJOURDHUI();"y")=0;DATEDIF(B11;AUJOURDHUI();"ym")=0); "new born"; DATEDIF(B11;AUJOURDHUI();"y") & "a " & DATEDIF(B11;AUJOURDHUI();"ym") & "m ")

Par contre, comment ajouter le fait que cela m'affiche : cellule vide en résultat si ma cellule Date de naissance = B11 est vide.

Merci d'avance.
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
24613
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2019
4839
1
Merci
bonsoir

=SI(B11="";"cellule vide";SI(ET(DATEDIF(B11;AUJOURDHUI();"y")=0;DATEDIF(B11;AUJOURDHUI();"ym")=0); "new born"; DATEDIF(B11;AUJOURDHUI();"y") & "a " & DATEDIF(B11;AUJOURDHUI();"ym") & "m "))
crtdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 64663 internautes nous ont dit merci ce mois-ci

Mandelle_9316
Messages postés
3
Date d'inscription
jeudi 10 octobre 2019
Statut
Membre
Dernière intervention
10 octobre 2019
-
Merci, mais je perds le résultat "new born" si je rentre la date de naissance 25/09/2019.
Mandelle_9316
Messages postés
3
Date d'inscription
jeudi 10 octobre 2019
Statut
Membre
Dernière intervention
10 octobre 2019
-
désolée, j'avais un espace de trop dans ma formule : avec votre modification elle fonctionne très bien.

Merci beaucoup. Bonne soirée.
Commenter la réponse de Vaucluse
Messages postés
24613
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2019
4839
0
Merci
pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse