TIME SHEETS / Mauvaise addition des heures [Résolu]

Messages postés
16
Date d'inscription
dimanche 2 décembre 2018
Statut
Membre
Dernière intervention
7 octobre 2019
- - Dernière réponse : Vaucluse
Messages postés
24565
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2019
- 7 oct. 2019 à 15:29
Bonjour,

Je travaille sur un document permettant de comptabiliser mes heures passées, chaque jour, par client. Et de convertir le tout en jours à la fin du mois.
Voici l'Excel : https://www.cjoint.com/c/IJhmZXMWfYV

Le fonctionnement est très simple : on sélectionne dans une liste déroulante le nombre d'heures passées.
Le souci de cette liste déroulante, c'est que les heures sont mal additionnées.
Pour la colonne bleue par exemple, si on sélectionne 8 heures le premier jour, puis 8 heures le deuxième jour... tout s'additionne bien en F4. Mais si on sélectionne également 8 heures le troisième jour... tout repasse à 0 heures en F4.
Savez-vous pourquoi ?

Dans un second temps, sauriez-vous comment ajouter une décimale pour le total de jours en colonne G ? Pour pouvoir avoir 24,5 jours par exemple, au lieu de 24 ou 25 uniquement.

Merci beaucoup par avance pour votre aide !

Nicolas
Afficher la suite 

1 réponse

Messages postés
24565
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2019
4821
0
Merci
Bonjour

le résultat est bon, alors simplement, formatez votre F4 en Nombre / personnalisé
entrez dans le cadre type:
[HH]:mm:ss
avec le HH entre crochets, sinon Excel n'affiche que le reste d'une division par 24 (alors que la valeur de la cellule est bien le total)
crdlmnt
Dozou
Messages postés
16
Date d'inscription
dimanche 2 décembre 2018
Statut
Membre
Dernière intervention
7 octobre 2019
-
Merci pour votre réponse, mais comment puis-je rentrer ces infos étant donné que j'ai déjà "=SOMME(B4:B27)" ? (je ne suis vraiment pas un connaisseur désolé).

Merci !
Vaucluse
Messages postés
24565
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2019
4821 -
Bonjour
rien à voir avec la formule, mais avec le formatage de cellule
  • clic droit sur la cellule
  • format de cellule
  • onglet dans la fenêtre: nombre
  • en bas à gauche "personnalisée"
  • dans le tableau cadre "type", entrez:
  • [hh]:mm (suffisant si vous n'avez pas de secondes à afficher)
  • et OK

c rdlmnt
Dozou
Messages postés
16
Date d'inscription
dimanche 2 décembre 2018
Statut
Membre
Dernière intervention
7 octobre 2019
-
Super merci beaucoup ça fonctionne nickel !
Vaucluse
Messages postés
24565
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2019
4821 -
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de Vaucluse