Problème Excel recherche valeur dans tableau

-
Bonjour,

J'ai un problème avec un tableau excel.
J'aimerai qu'en renseignant le département dans la case bleu le tableau me donne tous seul la zone dans la case juste en dessous.
J'ai essayé avec un index/equiv sans succès.

Ci-joint le tableau :
https://www.cjoint.com/c/IJdn6TskEB0


Configuration: Macintosh
Afficher la suite 

1 réponse

Messages postés
2485
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
11 octobre 2019
278
0
Merci
Bonjour à tous,

Un essai en retirant les ;
https://www.cjoint.com/c/IJdpYzeOdui


Crdlmt
Tout d’abord merci pour votre réponse, juste un problème étant sous mac je travail sur number.
J’ai essayé d’ouvrir votre fichier mais ça me met une erreur et supprime la formule.
J’ai donc ouvert votre fichier dans open office mais je ne comprend rien a votre formule et je n’arrive pas a la mettre dans number.
DjiDji59430
Messages postés
2485
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
11 octobre 2019
278 -
Je suis désolé, on est sur un forum excel et je ne sais pas si sommeprod() existe dans number

=SOMMEPROD(($D$4:$T$16=$B$1)*(ESTNUM(COLONNE(D:T)))*(LIGNE($C$4:$C$16)-3))

$D$4:$T$16=$B$1
On regarde quelle est la place de B dans la matrice $D$4:$T$16 (celle qui couvre toutes les valeur a tester

ESTNUM(COLONNE(D:T)
On crée la matrice des colonnes (qui va etre une suite de Vrai)

($D$4:$T$16=$B$1)*(ESTNUM(COLONNE(D:T)
On élimine les colonnes dans lesquelles il n'y a pas B1
(LIGNE($C$4:$C$16)-3))
donne une matrice qui va de 1==> 13

($D$4:$T$16=$B$1)*(ESTNUM(COLONNE(D:T)))*(LIGNE($C$4:$C$16)-3))

(Il reste une matrice de colonne avec des 0 et 1 1)*(LIGNE($C$4:$C$16)-3))
On obtient une matrice qui a éliminé les de n° de ligne avec les zeros de la colonne
dans la cas de la zone 4 par exemple
{0;0;0;4;0;0;0;0;0;0;0;0;0]

somme({0;0;0;4;0;0;0;0;0;0;0;0;0])=4


Crdlmt
Commenter la réponse de DjiDji59430