Calcul colonne en fonction de la colonne de gauche

- - Dernière réponse : Vaucluse
Messages postés
24358
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 septembre 2019
- 10 sept. 2019 à 18:37
Bonjour,

J'ai besoin de votre aide pour connaitre la formule qui résoudrait mon souci!!!

Je souhaite connaitre le nombre de valeurs d'une colonne en fonction de la colonne précédente.
Je m'explique:

Si j'ai "5" dans A1 et "3" dans A2, le résultat doit etre 0 (car la colonne A est remplie).
Si j'ai rien en A1 et "3" en A2, le résultat doit etre 1 (car la colonne A est vide).

Pour le total de la colonne A il me suffit de faire =NVAL(A1;A20) mais comment faire pour que la colonne B m'indique uniquement le nombre total de valeurs en B si les cellules correspondantes en A sont vides?

De même, j'aimerai que la colonne C ne comptabilise les valeurs en C que si A et/ou B sont vides?

Plusieurs heures que je me creuse la tête...

Merci à vous pour vos réponses.

Cdt

Marie

Configuration: Windows / Chrome 72.0.3626.121
Afficher la suite 

1 réponse

Messages postés
24358
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 septembre 2019
4752
0
Merci
Bonjour
=NB.SI.ENS(A:A;"";B:B"<>")
=NB.SI.ENS(A:A;"";B:B;"";C:C;"<>")
ect..
applicable à partir d'Excel 2013
avant (avec limite de lignes)
=SOMMEPROD((A1:A20="")*(B1:B20<>"")
=SOMMEPROD((A1:A20;"")*(B1:B20="")*(C1:C20<>""))
etc..
crdlmnt
Commenter la réponse de Vaucluse