Exercices à corriger

-
Bonjour,
un programme qui permet d'introduire 10 nombres puis affiche le nombre de fois qu'un nombre donné a été introduit
ma réponse n'est pas trop précise:
Algorithme nombre;
var N,a,i,c: entier;
Debut
lire(N);
a:=N;
c:=1;
pour i=1 à 9 faire
début
lire (N);
si N=a alors
debut
a:=N;
c:=c+1;
fin si;
fin pour;
Ecrire('le nombrea ',a,' s'est répété ', c,' fois');
fin.

sauf que cet essai me permet juste d'afficher le résultat pour le premier nombre que j'ai inséré en executant, mais l'énoncé nous dis n'importe quelle nombre parmis ces dix.
Merci
Afficher la suite 

2 réponses

Messages postés
8529
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
16 septembre 2019
423
0
Merci
bonjour, dans l'énoncé, je ne lis pas "n'importe quelle nombre parmi ces dix".
Commenter la réponse de yg_be
Messages postés
13730
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
17 septembre 2019
384
0
Merci
Bonjour à vous 2.
Je n’ai pas la même interprétation que toi yg_be, je pense qu’il faut compter les occurrences de chaque nombre saisi.

@Mouha, sais tu ce qu’est un tableau/une liste?
Commenter la réponse de Whismeril