Fonction si et cherche

-
Bonjour,

Je ne suis pas très doué en Excel et j'aurais besoin d'aide pour une formule.

Je recherche le résultat suivant.

Si A1 contient le mot "blabla", alors TEST, si A1 contient le mot "plus", alors TERMINE, etc etc... et j'en 6-7 conditions.

Dans mes différents essais, je n'arrive pas à faire d'autres "cherche".

=SI(CHERCHE("blabla",BC12),"TEST")

Et je n'arrive pas à intégrer le reste....

Configuration: Windows / Chrome 76.0.3809.132
Afficher la suite 

4 réponses

Messages postés
11083
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 septembre 2019
1413
0
Merci
Bonsoir,

Essaie par exemple pour 3 recherches :
=SI(NB.SI(A1;"*blabla*")=1;"TEST"; SI(NB.SI(A1;"*plus*")=1;"TERMINÉ";SI(NB.SI(A1;"*truc*")=1;"CHOSE";"Non trouvé")))

Tu peux ainsi en imbriquer 7 et ta fonction doit se terminer par 7 )

Cdlmnt
Via
Merci mais je copie la formule mais cela ne marche pas...Je m'arrache les cheveux et déjà que je n'en n'ai pas beaucoup ....
Commenter la réponse de via55
Messages postés
22884
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
14 septembre 2019
5629
0
Merci
Bonjour à tous,

autre façon de faire :
=INDEX({"test";"terminé"};EQUIV(A1;{"blabla";"plus"};0))

eric
Merci eriic mais je n'arrive pas l'intégrer non plus
Commenter la réponse de eriiic
Messages postés
11083
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 septembre 2019
1413
0
Merci
A Romain :
Poste ton fichier sur mon-partage.fr (avec la formule que tu as essayé de copier), copie le lien créé et reviens le coller ici, on regardera ce qui cloche

A Eric, amical salut
Perso j'ai compris qu'on ne recherchait pas la mot blabla en A1 mais si la chaine de caractères en A1 contient blabla (puisque essai avec le fonction CHERCHE) mais je me trompe peut être
https://mon-partage.fr/f/jnSYKTHA/

Voilà le fichier, c'est des données autres mais j'essaie de créer la formule pour l'adapter ensuite
Commenter la réponse de via55
Messages postés
11083
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 septembre 2019
1413
0
Merci
Ton fichier en retour, pas sur d'avoir bien compris
https://mon-partage.fr/f/mioAM0cs/
Via55! Merci je pense que tu as résolu mon problème. En fait, dependant de l'email de la personne, j'arrive à extraire le nom de l'entreprise car il y en a 5-6.

Merci beaucoup.Je prendrais bien tes coordonnées pour me dépanner à l'occasion :-) Merci beaucoup de ta générosité.

Je comprends pas trop ce que tu as changé par rapport à ta 1ere formule mais je regarderai cela attentivement histoire de pas mourrir bête.

Merci beaucoup
Romain
Commenter la réponse de via55