Fonction SI [Résolu]

- - Dernière réponse :  Mahieddine - 6 sept. 2019 à 15:27
Bonjour,
Bonjour
J'ai besoin de votre aide;
j'ai un fichier Excel avec plusieurs colonnes , dans la colonne A le numéro unique de la demande du ménage, dans la colonne B " nommée Demandeur principal" j'ai soit "Oui" soit "Non", dans la colonne C " Colonne des résultats des tests" soit "VRAI", soit "FAUX", mon soucis est le suivant:
je cherche une formule ou une fonction qui me permets de renvoyer les résultats des lignes de l'ensemble du mé,age qui porte le même numéro de la demande sur la ligne du demandeur principal. en gros si(ET(A:A=A2;B:B="Oui";C:C="FAUX");je veux que la valeur "FAUX" s'inscrire sur toutes les lignes qui portes le même numéro A), que la valeur "FAUX" et pas les "VRAI"
en gros si la cellule du demandeur principal est "VRAI" et les autres lignes du meme groupe sont "FAUX" il faut que la ligne du demandeur principal deviendra "FAUX"

Merci pour votre aide
Cordialement


Configuration: Windows / Edge 17.17134
Afficher la suite 

2 réponses

Messages postés
24401
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2019
4769
0
Merci
Bonjour
Pour qu'on puisse vous répondre correctement, il faudrait mettre à disposition un fichier (en anonymisant les données confidentielles) en y ajoutant quelques explications
voyez sur ce site
http://mon-partage.fr
déposez/créez le lien et revenez le coller ici
crdlmnt

Bonjour
Voici le lien pour mon fichier; je vous remercie

https://mon-partage.fr/f/K6pf4BEQ/
Cordialement
j'ai un fichier Excel avec plusieurs colonnes , dans la colonne A le numéro unique de la demande du ménage, dans la colonne B " nommée Demandeur principal" j'ai soit "Oui" soit "Non", dans la colonne C " Colonne des résultats des tests" soit "VRAI", soit "FAUX", mon soucis est le suivant:
je cherche une formule ou une fonction qui me permets de renvoyer les résultats des lignes de l'ensemble du mé,age qui porte le même numéro de la demande sur la ligne du demandeur principal. en gros si(ET(A:A=A2;B:B="Oui";C:C="FAUX");je veux que la valeur "FAUX" s'inscrire sur toutes les lignes qui portes le même numéro A), que la valeur "FAUX" et pas les "VRAI"
en gros si la cellule du demandeur principal est "VRAI" et les autres lignes du meme groupe sont "FAUX" il faut que la ligne du demandeur principal deviendra "FAUX"
Commenter la réponse de Vaucluse
Messages postés
2080
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 septembre 2019
411
0
Merci
Bonjour Mahieddine

Salutations Vaucluse

Ma proposition en D2

=SI(NB.SI.ENS(A:A;A2;B:B;"OUI";C:C;"FAUX")=1;"FAUX";C2)

Pour la fin de la formule je demande la reproduction de la cellule de gauche si la condition si est fausse.

Cordialement
PapyLuc51
Messages postés
2080
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 septembre 2019
411 -
Pas possible de mettre une formule et une indication entrée manuellement, peut-être possible par VBA (pas mon domaine)

Ou alors une MFC ; colorier les lignes concernées pour les faire ressortir

Ou encore sur la droite reproduire le tableau principal sans la dernière colonne et mettre cette formule sur les colonne 2 et 3 du nouveau tableau

=SI(NB.SI.ENS($A:$A;$A2;$B:$B;"OUI";$C:$C;"FAUX")=1;"FAUX";$C2)
attention à l'ajout de"$"

https://www.cjoint.com/c/IIgiMtvfC7u

Cordialement
> PapyLuc51
Messages postés
2080
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 septembre 2019
-
Merci à vous
PapyLuc51
Messages postés
2080
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 septembre 2019
411 -
Le même retour avec une MFC mise en place

https://www.cjoint.com/c/IIgkgfk0Qhu
Merci
je reviendrai vers vous très rapidement
Cordialement
Re Bonjour
Je viens de trouver la solution en détournant le problème autrement, j'ai rajouter une nouvelle colonne en lui demandant de de me calculer la somme des "FAUX" et la mettre sur le demandeur principal
Merci à vous
Commenter la réponse de PapyLuc51