Formule =Recherche [Résolu]

- - Dernière réponse :  Maxime - 4 sept. 2019 à 10:18
Bonjour,

Je suis malheureusement dans l'impasse, je m'explique...

Ci-dessous un lien pour accéder au tableur test que j'ai créé pour mieux illustrer mes propos :

https://docs.google.com/spreadsheets/d/16Rqd4K7oM_-fSNujfhUuKi2gdAKXSzqUZQyEm7PjXUA/edit?usp=sharing

J'ai deux feuilles Sheet, l'une est une BDD ("BDD") et l'autre est une fiche globale mensuelle ("Résultats")

Dans les deux feuilles, nous retrouvons les mêmes entreprises. Je souhaite faire afficher dans ma feuille "résultat" les prévisions pour les mois de septembre qui se trouve dans "BDD".

Pour ce faire j'ai utilisé cette formule : RECHERCHE(A2;BDD!$A$2:$A$23;BDD!$C$2:$C$23)
A2 : nom de l'entreprise
BDD!$A$2:$A$23 : nom des entreprises sur la feuille "BDD"
BDD!$C$2:$C$23 : les prévisions du mois de septembre affichées sur la feuille "BDD".

Cela fonctionne parfaitement, sauf que quand je souhaite trier ma BDD (par ordre alphabétique), les résultats dans la feuille "résultat" deviennent erronés.

Avez-vous la solution ?

Merci d'avance pour votre aide,

Très bonne journée à vous,

Maxime
Afficher la suite 

3 réponses

Messages postés
24414
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 septembre 2019
4773
0
Merci
Bonjour
essayez avec:
=VLOOKUP(A2,BDD!$A$2:$B$23,2;0)
(n'oubliez pas le 0 final qui permet de traiter une plage même si la colonne de recherche n'est pas classée
si vus êtes en version anglaise, les séparateurs sont des virgules, comme ci dessus, sinon utilisez des points-virgules
crdlmnt

Commenter la réponse de Vaucluse
0
Merci
Bonjour,

Essaie avec
=RECHERCHEV(A2;BDD!$A$2:$C$23;3;FAUX)

Cordialement.
Commenter la réponse de gyrus
0
Merci
Bonjour à tous les deux,

Merci beaucoup pour vos conseils !

Voici la formule que j'ai utilisée :
=RECHERCHEV(B3;bdd!B2:D18;3;0)

Je n'avais pas sélectionné toutes les colonnes et lignes en même temps.

Bonne journée !

Maxime
Commenter la réponse de Maxime