Formule de calcul

- - Dernière réponse : diablo13800
Messages postés
1903
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2019
- 5 sept. 2019 à 14:15
Bonjour,
Comment copier cette formule à suivre(à la place du 1 il me faut 2 qui correspond au 52 semaine

=SOMME.SI.ENS('sem 20'!D5:D50;'sem 20'!B5:B50;1)+SOMME.SI.ENS('sem 20'!G5:G50;'sem 20'!E5:E50;1)+SOMME.SI.ENS('sem 20'!J5:J50;'sem 20'!H5:H50;1)+SOMME.SI.ENS('sem 20'!M5:M50;'sem 20'!K5:K50;1)+SOMME.SI.ENS('sem 20'!P5:P50;'sem 20'!N5:N50;1)

Configuration: Windows / Firefox 68.0
Afficher la suite 

4 réponses

Messages postés
1903
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2019
723
0
Merci
Bonjour,

Il vous suffit de remplacer le 1 par le 2 ...
=SOMME.SI.ENS('sem 20'!D5:D50;'sem 20'!B5:B50;2)+SOMME.SI.ENS('sem 20'!G5:G50;'sem 20'!E5:E50;2)+SOMME.SI.ENS('sem 20'!J5:J50;'sem 20'!H5:H50;2)+SOMME.SI.ENS('sem 20'!M5:M50;'sem 20'!K5:K50;2)+SOMME.SI.ENS('sem 20'!P5:P50;'sem 20'!N5:N50;2)

Commenter la réponse de diablo13800
0
Merci
Bonjour

Mais comment faire à suivre sur les 52 semaines, car je change à chaque fois le 1 par 2 et ainsi de suite
et j'ai prés de 500 lignes
diablo13800
Messages postés
1903
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2019
723 -
La précision n'est pas la même la :)

Le mieux serait que vous envoyez un échantillon de votre tableau ( en supprimant les données trop personnelles s'il y a) grace à ce site :
http://cjoint.com
Commenter la réponse de jeanluc.tillaud44@gmail.com
Messages postés
9116
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 septembre 2019
1626
0
Merci
Bonjour à tous les deux

Ta formule
1. Dans quelle cellule est elle ?
2. Tu veux la copier où ?

Suis le conseil de diablo13800 et utilises https://www.cjoint.com/

Cdlmnt
diablo13800
Messages postés
1903
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2019
723 -
Bonjour,

Votre numéro de semaine étant en C2. Vous pouvez juste remplacer 1 par C$2.

Suite à cela vous pouvez étirer votre formule.

Cependant, un problème se posera sur le nom des onglets.
-
Merci, mais le problème est sur la fin de la formule ,je veux remplacer le par 2 jus-qua 52 sur toute la fin de formule les chiffre a suivre
diablo13800
Messages postés
1903
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2019
723 -
Bonjour,

Votre numéro de semaine est indiqué en ligne 2. Votre formule peut devenir:
=SOMME.SI.ENS('sem 20'!D5:D50;'sem 20'!B5:B50;C$2)+SOMME.SI.ENS('sem 20'!G5:G50;'sem 20'!E5:E50;C$2)+SOMME.SI.ENS('sem 20'!J5:J50;'sem 20'!H5:H50;C$2)+SOMME.SI.ENS('sem 20'!M5:M50;'sem 20'!K5:K50;C$2)+SOMME.SI.ENS('sem 20'!P5:P50;'sem 20'!N5:N50;C$2)
-
merci,
mais cela ne marche pas sa change tous et je veux que le changement de la semaine (dernier chiffre)
diablo13800
Messages postés
1903
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2019
723 -
Bonjour,

Pour moi cela fonctionne, mais pour l'étendre vous devez verrouillé les cases que ne bougeront pas grâce à $.

ex:
=SOMME.SI.ENS('sem 20'!$D$5:$D$50;'sem 20'!$B$5:$B$50;C$2)+SOMME.SI.ENS('sem 20'!$G$5:$G$50;'sem 20'!$E$5:$E$50;C$2)+SOMME.SI.ENS('sem 20'!$J$5:$J$50;'sem 20'!$H$5:$H$50;C$2)+SOMME.SI.ENS('sem 20'!$M$5:$M$50;'sem 20'!$K$5:$K$50;C$2)+SOMME.SI.ENS('sem 20'!$P$5:$P$50;'sem 20'!$N$5:$N$50;C$2)
Commenter la réponse de ccm81
0
Merci
Merci,

impeccable
-
Bonjour,

J'aurai encore une question,comment recopier la formule en glissant vers le bas tous en changeant le dernier chiffre
exemple
C$2 par C$3, et ainsi de suite

merci
diablo13800
Messages postés
1903
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2019
723 -
Bonjour,

Il suffit de ne pas verrouiller la cellule:
mettez C2 au lieu de C$2
-
Bonjour, j'ai déjà essayer et cela ne fonctionne pas
-
Bonjour ,

juste pour vous remercier et de vous signaler que j'ai trouver le système
diablo13800
Messages postés
1903
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2019
723 -
Quel était le soucis du coup ?
Commenter la réponse de jeanluc.tillaud44@gmail.com