Proxmox configuration IPV6 pour les containers

Messages postés
99
Date d'inscription
dimanche 18 janvier 2009
Statut
Membre
Dernière intervention
1 septembre 2019
- - Dernière réponse : teddy76db
Messages postés
99
Date d'inscription
dimanche 18 janvier 2009
Statut
Membre
Dernière intervention
1 septembre 2019
- 1 sept. 2019 à 23:58
Bonjour tout le monde,
je suis très embêté sur un problème depuis maintenant 4 jours avec Proxmox.
Si avez l'aimabilité de m'aider ce serait super sympathique car je suis dans l'impasse...

Mon projet :

Je souhaite avec Proxmox créer plusieurs Containers pour y faire tourner quelques applications, ces applications necéssitent une adresse IP unique pour chaque containers,
je souhaiterai donc utilisé le BLOC IPV6 fourni par mon prestataire qui le bloc suivant :

Assigned IPs 2a04:2180:1:15::/64
2a04:2180:ffff:fffe::15
fe80::/64

IPv6 Nameservers 2a04:2180::101:53 - 2a04:2180::102:53
IPv6 Gateway 2a04:2180:0:2::1


J'ai tout essayé pour essayer de faire fonctionner les containers, mais maintenant je suis vraiment bloqué car je ne peux vraiment plus avancer, car à chaque modification effectué,
le service networking ne veut pas redémarrer, pourriez-vous m'aider à configurer la partie IPV6 de mon fichier pour que l'hôte est accès à internet via l'IPV6 et pour que les containers,
aient aussi une adresse IPV6 unique (tout en ayant effectué un petit NAT pour leur permettre l'accès IPV4).

J'ai l'impression que ma configuration ne permets pas de joindre la gateway IPV6...

Voici mon fichier de configuration actuel,
j'utilise le périphérique vmbr0 mis en place d'origine par Proxmox, j'ai donc effectué les modifications necéssaires :

The loopback network interface
auto lo
iface lo inet loopback

The primary network interface
auto enp2s0f0
iface enp2s0f0 inet static
address 185.64.XXX.111
netmask 255.255.255.0

broadcast 185.64.XXX.111
post-up route add 185.64.XXX.1 dev enp2s0f0
post-up route add default gw 185.64.XXX.1 dev enp2s0f0

iface enp2s0f0 inet6 static
address 2A04:2180:0001:0015:0000:0000:0000:0001
netmask 64
post-up /sbin/ip -r route add 2a04:2180:0:2::1 dev enp2s0f0
post-up /sbin/ip -r route add default via 2a04:2180:0:2::1


En vous remerciant énormément pour votre aide, franchement, cette histoire me tape sur les nerfs...
Merci !
Afficher la suite 

1 réponse

Messages postés
1430
Date d'inscription
mercredi 31 août 2011
Statut
Membre
Dernière intervention
9 septembre 2019
69
0
Merci
Salut,

Les commentaires ne sont pas commentés.

Tu peux utiliser
gateway xx.xx.xx.xx
plutot que de post-up {route,ip} pour l'ajout de la route par default.

Tu n'es pas omogéne dans ton fichier. Un coup tu utilises route, un autre la commande ip route.

En ajoutant la gateway tel que dans le code suivant, les routes pour ton réseau doivent se monter seules :
#The loopback network interface
auto lo
iface lo inet loopback

#The primary network interface
auto enp2s0f0
iface enp2s0f0 inet static
    address 185.64.XXX.111
    netmask 255.255.255.0
    broadcast 185.64.XXX.111
    gateway 185.64.XXX.1

iface enp2s0f0 inet6 static
    address 2A04:2180:0001:0015:0000:0000:0000:0001
    netmask 64
    gateway 2a04:2180:0:2::1


Pour revenir à la commande ip, tu n'indiques pas le flag -6.
/sbin/ip -6  -r route add default via 2a04:2180:0:2::1


Test les commandes à la main avant de passer par un script de configuration, need root.

Tu peux lister tes routes avec :
ip -6 r

Tu peux tester la route qui sera utiliser pour une ip avec :
ip -6 route get  2a04:2180:0:2::1


Une fois que tes routes sont fonctionnelle, met les en static dans ton fichier de conf.

Tu peux avoir des traces / infos dans
/var/log/syslog
, le service networking log dans ce fichier.

A plus,

N'oubliez pas de marquez votre post comme résolut lorsque vous avez eu les réponses à vos questions...
Au royaume des aveugles, les borgnes sont rois.
teddy76db
Messages postés
99
Date d'inscription
dimanche 18 janvier 2009
Statut
Membre
Dernière intervention
1 septembre 2019
3 -
Merci beaucoup pour ta réponse !
j'ai recommencé à zero, j'ai tout ré-éditer selon vos conseils voici la configuration :

    #The loopback network interface
auto lo
iface lo inet loopback

#The primary network interface
auto enp2s0f0
iface enp2s0f0 inet static
address 185.64.XXX.111
netmask 255.255.255.0

broadcast 185.64.XXX.111
post-up route add 185.64.XXX.1 dev enp2s0f0
post-up route add default gw 185.64.XXX.1 dev enp2s0f0

iface enp2s0f0 inet6 static
address 2a04:2180:ffff:fffe::15
netmask 64
post-up /sbin/ip -r route add 2a04:2180:ffff:fffe:ffff:ffff:ffff:fffe dev enp2s0f0
post-up /sbin/ip -r route add default via 2a04:2180:ffff:fffe:ffff:ffff:ffff:fffe

auto vmbr0
iface vmbr0 inet static
address 10.10.10.1
netmask 255.255.255.0
bridge_ports none
bridge_stp off
bridge_fd 0
post-up echo 1 > /proc/sys/net/ipv4/ip_forward
post-up iptables -t nat -A POSTROUTING -s '10.10.10.0/24' -o enp2s0f0 -j MASQUERADE
post-down iptables -t nat -D POSTROUTING -s '10.10.10.0/24' -o enp2s0f0 -j MASQUERADE

###START IPv4 NAT PORT FORWARDING
post-up iptables -t nat -A PREROUTING -i enp2s0f0 -p tcp --dport 10022 -j DNAT --to 10.10.10.100:22
post-down iptables -t nat -D PREROUTING -i enp2s0f0 -p tcp --dport 10022 -j DNAT --to 10.10.10.100:22

post-up iptables -t nat -A PREROUTING -i enp2s0f0 -p tcp --dport 10180 -j DNAT --to 10.10.10.101:80
post-down iptables -t nat -D PREROUTING -i enp2s0f0 -p tcp --dport 10180 -j DNAT --to 10.10.10.101:80
###END IPv4 NAT PORT FORWARDING

auto vmbr0
iface vmbr0 inet6 static
address 2a04:2180:0001:0015:0000:0000:0000:0001
netmask 64
bridge_ports none
bridge_stp off
bridge_fd 0
post-up echo 1 > /proc/sys/net/ipv6/conf/all/proxy_ndp
post-up echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
post-up echo 1 > /proc/sys/net/ipv6/conf/default/forwarding
post-up /sbin/ip -f inet6 neigh add proxy 2a04:2180:0001:0015:0000:0000:0000:0001 dev vmbr0

###START GUEST IPv6
post-up /sbin/ip -f inet6 neigh add proxy 2a04:2180:0001:0015:0000:0000:0000:0002 dev enp2s0f0
post-up /sbin/ip -f inet6 route add 2a04:2180:0001:0015:0000:0000:0000:0002 dev vmbr0

post-up /sbin/ip -f inet6 neigh add proxy 2a04:2180:0001:0015:0000:0000:0000:0003 dev enp2s0f0
post-up /sbin/ip -f inet6 route add 2a04:2180:0001:0015:0000:0000:0000:0003 dev vmbr0
###END GUEST IPv6


Je ne vois aucun problème dans la configuration et pourtant rien ne veut fonctionner...

J'ai même mis en place un NAT en IPV4, j'ai permis l'assignation manuelle d'IPV6 aux containers, mais je n'ai aucune connexion fonctionnelle sur la machine et je ne peux pas redémarrer le réseau avec la commande "/etc/init.d/networking restart",
j'ai beau lire et relire la configuration je ne vois aucune erreur...

Qu'en pensez-vous ? Merci bien !
Commenter la réponse de Exileur