Lecture fichiers MP4 sans image (VLS, WMP, WMM)

Messages postés
767
Date d'inscription
dimanche 28 septembre 2008
Statut
Membre
Dernière intervention
1 septembre 2019
- - Dernière réponse : jeannets
Messages postés
15983
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 septembre 2019
- 1 sept. 2019 à 16:33
Bonjour,
J'ai un défaut aléatoire : VLC, Windows Media Player et Windows Movie Maker, sous Windows 7 Family, n'affichent pas la vidéo MP4, seul le son fonctionne. Si je reboote le PC ça refonctionne un certain temps puis à nouveau le problème revient. Je n'ai pas ce problème avec MPC-HC chargé entretemps pour me dépanner.
Avast scan complet : RAS.
Malwarebytes scan complet : 2 fichiers suspects mis en quarantaine
Ccleaner passé
Installation de K-Lite Codec Pack Full sans effet
Quelqu'un a une idée de ce qui se passe ?
Merci par avance.


Configuration: Windows XP, Office 2003 ou 2007 (perso)
Windows 7, Office 2010 (pro)
Windows Phone Lumia 820

Afficher la suite 

2 réponses

Messages postés
15983
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 septembre 2019
1637
0
Merci
Bonjour,

Ce qui se passe..?? à travers un forum et sans vraiment de détails techniques, on ne peut pas le savoir... On peu seulement supposer... ou poser des questions complémentaires pour deviner davantage.

-- est-ce que tu regardes ça sur un écran de PC...?? PC tour ou PC portable... le modèle serait un plus. Ton PC peut aussi ne pas etre assez rapide; pour ce type de vidéo.
-- Quelle est la source de cette vidéo..?? Téléchargée, une émission enregistrée, un caméscope, un smartphone..??
-- Mon intuition est que le problème vient du fichier vidéo... Mais il faudrait en connaitre les caractéristiques. Pour celà, le passer dans les propriétés du logiciel "Média info" https://mediaarea.net/fr/MediaInfo l'installer sur ton PC... puis sur ton fichier vidéo==>clic droit==>Vue==Texte et ce texte tu le copie et le colle ici sur ton prochain POST..

-- Probablement il faudra que tu envisages de le Ré-encoder pour réparer ça. Es-tu prêt à faire ça.

-- Il serait également bien de savoir si toutes tes vidéos font ça..?? ou bien il n'y a que celle-ci..?
stefanodimecanic
Messages postés
767
Date d'inscription
dimanche 28 septembre 2008
Statut
Membre
Dernière intervention
1 septembre 2019
140 -
SAlut ! Le PC est une Tour ACER Série Aspire modèle AM3400. Windows 7 Famille, processeur AMD Athlon II X2 220, 3Go de RamDDR3, vidéo ATI Radeon HD4250.
Le défaut est sur un film monté avec WMM et rpoduit en MP4. Sur les anciens fichiers certains fonctionnent et d'autres non.
Pour le fichier visé voici le texte issu de Madiainfo :
Général
Nom complet : J:\Dossier Sylvie\PIERRE FROMENT\2018 2019\ACHALTL'HAND 2018 2019.mp4
Format : MPEG-4
Profil du format : Base Media / Version 2
Identifiant du codec : mp42 (mp41/isom)
Taille du fichier : 391 Mio
Durée : 7 min 50s
Débit global moyen : 6 963 kb/s

Vidéo
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Profil du format : Baseline@L4
Paramètres du format : 1 Ref Frames
Paramètres du format, CABAC : Non
Paramètres du format, RefFrames : 1 image
Paramètres du format, GOP : M=1, N=15
Identifiant du codec : avc1
Identifiant du codec/Info : Advanced Video Coding
Durée : 7 min 50s
Durée de la source duration : 7 min 51s
Débit : 6 829 kb/s
Largeur : 1 440 pixels
Hauteur : 1 080 pixels
Format à l'écran : 4/3
Type d'images/s : Constant
Images par seconde : 29,970 (29970/1000) Im/s
Espace de couleurs : YUV
Sous-échantillonnage de la chrominance : 4:2:0
Profondeur des couleurs : 8 bits
Type de balayage : Progressif
Bits/(Pixel*Image) : 0.147
Taille du flux : 383 Mio (98%)
Taille du flux source : 383 Mio (98%)
mdhd_Duration : 41540
Codec configuration box : avcC

Audio
ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Identifiant du codec : mp4a-40-2
Durée : 7 min 50s
Type de débit : Constant
Débit : 128 kb/s
Canaux : 2 canaux
ChannelLayout : L R
Echantillonnage : 48,0 kHz
Images par seconde : 46,875 Im/s (1024 SPF)
Mode de compression : Avec perte
Taille du flux : 7,35 Mio (2%)
mdhd_Duration : 41479
Commenter la réponse de jeannets
Messages postés
15983
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 septembre 2019
1637
0
Merci
Je te conseille de réencoder cette vidéo avec de nouveaux paramètres soit en utilisant l'outil FFmpeg voir tuto avec image ici https://fr.wikihow.com/utiliser-FFmpeg
Soit en utilisant le logiciel "AVIdemux" https://www.commentcamarche.net/download/telecharger-34055660-avidemux voir aussi "AVIdemux64" https://avidemux.fr.uptodown.com/windows

Je te joins le médiainfo d'une Vidéo en MP4 dans une version de plus faible définition... mais tu peux regarder les exemples et les valeurs utilisées... Je trouve le tient beaucoup trop gros pour 8 min de vidéo, il frole les 400Mo alors que le mien fait 550Mo et dure 1:22 heure je pense que c'est ça le problème... je continue en dessous.

Général
Nom complet : \\Dossier\Cholestérol le grand bluff_Arte_2016_10_18_20_50.mp4
Format : MPEG-4
Profil du format : Base Media / Version 2
Identifiant du codec : mp42
Taille du fichier : 548 Mio
Durée : 1h 22mn
Type de débit global : Variable
Débit global moyen : 928 Kbps
Date d'encodage : UTC 2016-10-11 13:37:11
Date de marquage : UTC 2016-10-11 13:37:11

Vidéo
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Profil du format : Main@L3.1
Paramètres du format, CABAC : Oui
Paramètres du format, RefFrames : 3 images
Identifiant du codec : avc1
Identifiant du codec/Info : Advanced Video Coding
Durée : 1h 22mn
Type de débit : Constant
Débit : 800 Kbps
Largeur : 640 pixels
Hauteur : 360 pixels
Format à l'écran : 16/9
Type d'images/s : Constant
Images par seconde : 25,000 Im/s
Norme : PAL
Espace de couleurs : YUV
Sous-échantillonnage de la chrominance : 4:2:0
Profondeur des couleurs : 8 bits
Type d'image : Progressif
Bits/(Pixel*Image) : 0.139
Taille du flux : 472 Mio (86%)
Date d'encodage : UTC 2016-10-11 13:37:11
Date de marquage : UTC 2016-10-11 13:37:11

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Profil du format : LC
Identifiant du codec : 40
Durée : 1h 22mn
Type de débit : Variable
Débit : 125 Kbps
Débit maximum : 255 Kbps
Canaux : 2 canaux
Position des cannaux : Front: L R
Echantillonnage : 48,0 KHz
Mode de compression : Avec perte
Taille du flux : 74,1 Mio (14%)
Date d'encodage : UTC 2016-10-11 13:37:11
Date de marquage : UTC 2016-10-11 13:37:11


Ton audio est bon, tu peux simplement le recopier identique dans les paramètres. C'est la partie Vidéo qui me chagrine... La fréquence est 6900Kb/sc alors que 2000 suffisent bien... En référence frame, tu n'as qu'une image... c'est trop fragile, il vaut mieux trois images... également ton format d'image 1440x1080 Tu peux aussi diminuer à 960x720, l'écran affichera quand même... mais tu peux aussi laisser ce format, ce n'est que pour diminuer la taille du fichier et les décrochages...

Il faut aussi laisser le PC se consacrer uniquement à cette tâche, c'est préférable... et ne pas avoir d'autres activités en tâche de fond pendant l'encodage.... je conseille l'encodeur FFmpeg pour sortir dans du MP4

Voilà quelques points qui seraient à revoir lors de ton ré-encodage... Mais bon, tu fait comme tu veux..
mais pour moi, c'est là dedans que se trouve la raison de tes décrochages vidéo.
stefanodimecanic
Messages postés
767
Date d'inscription
dimanche 28 septembre 2008
Statut
Membre
Dernière intervention
1 septembre 2019
140 -
Hello ! je ne suis pas un spécialiste comme toi, il va me falloir un peu de temps pour bien tout comprendre ... :-)
Petite explication, cette vidéo est en fait un montage de photos auquel mon épouse ajoute une bande son. Beaucoup plus simple et léger d'un PPT, surtout quand on veut le transmettre. De plus elle les porte souvent sur clé USB pour les visualiser sur TV. Ceci peut expliquer la taille des images, WMM ne doit pas retoucher la dimension, à moins qu'il n'y ait quelque chose à regarder dans les paramétrages. D'un autre côté si c'est pour être visualiser sur TV HD c'est peut-être le bon format.
Merci déjà pour ce retour.
jeannets
Messages postés
15983
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
18 septembre 2019
1637 -
OK, merci pour le spécialiste...! Mais Bon, il y a plus spécialiste que moi. Bref

Si je comprends mieux, ce n'est pas vraiment une vidéo... c'est plutot une bande assemblée de Photos, Je n'ai jamais fait ça, mais pour ton cas, je pense quand même que c'est la fréquence trame et la taille du fichier qui font ça... Je t'ai trouvé un tuto sur MVM http://epnstmichel.free.fr/wp-content/supports/image/movie_maker01.pdf Je pense que tu sais bien t'en servir pour ce qui est du montage des images et du son.. J'attire davantage ton attention sur la fin du tuto page 10 sur les fréquences utilisées, regarde bien les différences...


Vitesse= 2.0 Mbps et non pas 6.9
Taille d'affichage ... Tu peux mettre la tienne
image par secondes=25 et non pas 29,970

ça changera déja les choses....

Si par la suite, tu veux le modifier en MP4 tu peux lire ce sujet qui ressemble à ton cas https://www.commentcamarche.net/forum/affich-27152340-conversion-d-une-video-wmv-en-mp4-avec-vlc

ici, voir la partie 2 https://videoconverter.wondershare.com/convert-wmv/convert-wmv-to-mp4.html

Tu peux aussi utiliser le logiciel AVIdemux que j'ai cité hier dans mon POST N°3 voici un tuto pour AVIdemux https://quick-tutoriel.com/lencodage-video-pour-les-nuls-avec-avidemux/
Dans ton cas, tu mets le codage vidéo sur MP4 ASP (XVID) et pour l'audio, tu met COPY. pour les autres reglages... dans le doute, tu laisse faire... sinon, tu t'inspire de ce que j'ai déja cité dans mes exemples
Surtout la fréquence du BitRate autour de 2000 kHz le frame rate=25 images/sec
Tu peux aussi tenter les images au format 16/9 car c'est le format des écrans actuels .. Alors que tu mets du 4/3 qui n'est presque plus existant et qui a l'inconvénient d'étirer les images.. sur écran 16/9..

Et aussi, tu peux faire plusieurs essais..

Voila, bon codage..
Commenter la réponse de jeannets