Fonction rappel de donnée sur google sheet [Résolu]

-
Bonjour,

Je ne trouve pas de moyen "académique"ou de formule sur google sheet (sans exploiter l'erreur d'une formule connu...) pour renvoyer le contenant de la dernière cellule d'une colonne.

Connaissait vous la formule pour renvoyer la dernière valeur d'une colonne ? (j'utilise la valeur défaut de la fonction rechercheV)

Merci d'avance
Afficher la suite 

4 réponses

Messages postés
49887
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 septembre 2019
10701
0
Merci
Bonjour.

Je ne connais pas Google Sheet ; mais dans Excel, le terme "contenant" n'existe pas ; surtout que juste après tu parles de valeur ... Voulais-tu dire "référence ?"
Essaie =RECHERCHE(999999;AA)
(je recherche le contenu d'une cellule et j'utilise RECHERCHEV qui lorsqu'il ne trouve pas une valeur dans une colonne renvoie par défaut la dernière valeur de la collonne de recherche) "=RECHERCHEV(100^100;A:A;1)"
Commenter la réponse de Raymond PENTIER
Messages postés
2080
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 septembre 2019
411
0
Merci
Bonjour

En m'inspirant de cette page

pour une recherche de la dernière valeur nombre de la colonne A

=RECHERCHEV(9^9;A:A;1)

Par contre (comme mis en gras) ça ne trouve pas du texte même si c'est inscrit dans la dernière cellule.

Cordialement
Commenter la réponse de PapyLuc51
Messages postés
2080
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 septembre 2019
411
0
Merci
Re :

Je calais car j'avais trouvée la formule pour trouver la dernière cellule texte qui était

=RECHERCHEV("zz";A:A;1)
mais je n'arrivais pas à combiner les deux.

Et puis à force de chercher on arrive à trouver ;)

Pour avoir la dernière cellule renseignée (nombre ou texte) dans la colonne A
C'est une formule matricielle qui, sur google sheet, s'écrit comme ceci :

=ArrayFormula(RECHERCHE(2;1/(A:A<>"");A:A))

pour rentrer la formule en combinaison de touche

=RECHERCHE(2;1/(A:A<>"");A:A) Ctrl+touche Maj+Enter et faire une deuxième fois Enter après avoir relâché les autres touches


Cordialement
merci beaucoup oui effectivement je faisant également une rechercheV avec un nombre tellement grand qu'il n'y aura jamais d'occurance dans mon tableau
merci encore
Commenter la réponse de PapyLuc51
Messages postés
2080
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 septembre 2019
411
0
Merci
Bonjour,

Alors si je comprends bien ta réponse >>(n°5)<< ;

Ce que tu n'avais pas mentionné au départ c'est de trouver une valeur dans la colonne de recherche et si celle-ci n'y est pas afficher la dernière valeur de la colonne

Si la colonne de recherche ne contient que des nombres
Valeur a rechercher en B1 : cette formule

=SIERREUR(RECHERCHEV(B1;$A:$A;0);RECHERCHEV(9^9;$A:$A;1))

Si la colonne de recherche contient à la fois des nombres et du texte

=SIERREUR(RECHERCHEV(B1;$A:$A;0);ArrayFormula(RECHERCHE(2;1/($A:$A<>"");$A:$A)))

j'ai fais plusieurs essais et ça fonctionne pour les deux formules

Cordialement
Commenter la réponse de PapyLuc51