Recherche de dizaines manquantes

-
Bonjour, a tous
dans un tableau excel je voudrais sur une ligne savoir si il manque une dizaine
par exemple 17;25;27;35;45 sur ces 5 cellules il me manque la série 0-9 je ne sais comment on l'appel? quarantaine, trentaine, vingtaine, dizaine, zérotaine? il suffit que je le signale par un o ou x ; mes cellules sont toujours au nombre de 5 et les nombres de 1 à 49
merci pour vos réponses



Configuration: Windows / Edge 17.17134
Afficher la suite 

6 réponses

Meilleure réponse
Messages postés
11106
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 septembre 2019
1428
1
Merci
Bonjour

Avec les 5 nombres en B2:F2 :
=SI(NB.SI(B2:F2;"<10")=0;"x";SI(NB.SI.ENS(B2:F2;">=10";B2:F2;"<20")=0;"x";SI(NB.SI.ENS(B2:F2;">20";B2:F2;"<30")=0;"x";SI(NB.SI.ENS(B2:F2;">=30";B2:F2;"<40")=0;"x";SI(NB.SI(B2:F2;">=40")=0;"x";"")))))

Cdlmnt
Via

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 60301 internautes nous ont dit merci ce mois-ci

merci de ta reponce mais j'ai un prob
E F G H I J
119 1 19 20 30 48 =SI(NB.SI(E119:I119;"<10")=0;"x";SI(NB.SI.ENS(E119:I119;">=10";E119:I119;"<20")=0;"x";SI(NB.SI.ENS(E119:I119;">20";E119:I119;"<30")=0;"x";SI(NB.SI.ENS(E119:I119;">=30";B2:F2;"<40")=0;"x";SI(NB.SI(E119:I119;">=40")=0;"x";"")))))
j ai des erreurs je t'ai mis mes absices et ordonnées
Commenter la réponse de via55
Messages postés
11106
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 septembre 2019
1428
1
Merci
Pourquoi SOMMEPROD ?
Poste un exemple de ton fichier sur mon-partage.fr, copie le lien créé et reviens le coller ici

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 60301 internautes nous ont dit merci ce mois-ci

il y a un problème sur la vongtaine QUAND JE METS 20 C'EST FAUX 21 C'EST BON,,,partout ailleurs c'est bon ???
se serait super si on pouvait solutionner le 20 cordialement et merci
Commenter la réponse de via55
Messages postés
22889
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 septembre 2019
5637
1
Merci
Bonjour à tous,

autre technique :
=SOMMEPROD((GAUCHE(DROITE("0"&B2:F2;2);1)-{0\1\2\3\4}))=0

si chaque dizaine présente => VRAI
eric

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 60301 internautes nous ont dit merci ce mois-ci

Commenter la réponse de eriiic
Messages postés
9116
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 septembre 2019
1626
1
Merci
Bonjour à tous

A y être, une solution avec macro
https://mon-partage.fr/f/knV79UHv/

Cdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 60301 internautes nous ont dit merci ce mois-ci

Commenter la réponse de ccm81
0
Merci
une erreur il manque 0 a 9
Commenter la réponse de jack
0
Merci
merci pour ta réponse mais j'ai un problème
je te reflète une ligne de mes calcul s ainsi que la formule
ai je une erreur? ca ne marche pas
E F G H I J
119 8 19 42 44 48 =SOMMEPROD(((F119:J119)-E119:I119)>10)*E119:J119)
E F G H I J sont mes colonnes
119 est mon numéro de ligne
J est ma cellule de calcul
merci pour ton retour
Commenter la réponse de jack