Menu déroulant semi automatique

- - Dernière réponse : ccm81
Messages postés
9118
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 septembre 2019
- 28 août 2019 à 17:02
Bonjour,

bien que les explications soient claires, impossible pour moi d'obtenir ce que je veux, toutes les étapes précédentes fonctionnent mais je ne parviens pas à avoir la possibilité de taper les 1eres lettres dans le menu déroulant pour obtenir ma recherche....cela vient du fait que je dois me tromper à cette étape.
Je ne comprends pas par quoi je remplace A1 dans la formule ....c'est quoi la 1ère cellule ayant une validation par liste?pour ma part j'obtiens un menu déroulant avec des formules , i_noms etc.....?????

Merci de votre aide cela fait des semaines que j'y suis!!


Lorsque la liste est longue, il est souhaitable de pouvoir la scinder en fragments en saisissant le début du nom souhaité. Pour cela nous allons reprendre le menu de "validation"

Dans l'onglet "Alerte d'erreur" nous allons décocher "Quand les données..."
Dans l'onglet "Options" dans la zone "Source :" nous allons saisir la formule suivante :

=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMMEPROD((STXT(l_noms;1;NBCAR(A1))=TEXTE(A1;"0"))*1));l_noms)

en remplaçant A1 par l'identification de la première cellule sélectionnée (c'est-à-dire la 1ère cellule ayant une validation par liste).
Nous cliquons sur "OK" pour valider et sortir de la fenêtre.
Afficher la suite 

1 réponse

Messages postés
9118
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 septembre 2019
1627
0
Merci
Bonjour

Dans ta formule
- d_noms doit être la première cellule de la liste des noms
- l_noms est la liste des noms
- A1 est la cellule concernée par la validation des données

Si c'est ok, ta formule semble correcte

Pour utiliser tu dois entrer la/les première/s lettres et sélectionner le nom
un exemple détaillé > https://mon-partage.fr/f/q6vIUA1Y/

Si ça ne va toujours pas, envoies ton fichier

Cdlmnt
Commenter la réponse de ccm81