Table indiquée comme `utilisé` sur phpmyadmin

Messages postés
2
Date d'inscription
mercredi 28 août 2019
Statut
Membre
Dernière intervention
28 août 2019
- - Dernière réponse : tacosanxiety
Messages postés
2
Date d'inscription
mercredi 28 août 2019
Statut
Membre
Dernière intervention
28 août 2019
- 28 août 2019 à 21:04
Bonjour,

Je travaille actuellement sur une plateforme web dont la base de données est sous mySQL. Un bug récurrent est apparu à de nombreuses reprises et je n'ai toujours pas d'autres solutions qu'un mysqldump.

Ce bug est le suivant: une table de la base de données, sans raison apparente, devient inutilisable et probablement corrompue. Dans phpmyadmin, la table est indiquée comme `utilisé\``et il est impossible d'en lire les données, si elles existent toujours. Vous pouvez observer l'affichage de ceci sur le screenshot ci-dessous.



Il est possible que ce bug soit dû à des interactions avec la table, mais fort peu probable que ces interactions n'aient jamais eu lieu auparavant.

Sur un autre forum, j'ai pu retrouvé quelqu'un ayant eu le même problème, et l'ayant fixé en changeant le storage engine de sa table de InnoDB vers ISAM, ce que j'ai fait la table étant sous InnoDB avant cela.

Je n'ai pas d'autres pistes et j'aimerais à tout prix éviter que cela se reproduise.

Merci pour vos réponses.
Afficher la suite 

1 réponse

Messages postés
26282
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
15 septembre 2019
1783
0
Merci
Bonjour,

Essayes de voir si ta table n'est pas "lockée"
UNLOCK TABLES

tacosanxiety
Messages postés
2
Date d'inscription
mercredi 28 août 2019
Statut
Membre
Dernière intervention
28 août 2019
-
Malheureusement, cela n'a eu aucun effet. Je pense qu'ici, la table est probablement corrompue, car je n'arrive à récupérer aucune donnée.
Commenter la réponse de jordane45