Concaténer des cellules dans Excel

Messages postés
16
Date d'inscription
mardi 10 juillet 2018
Statut
Membre
Dernière intervention
29 août 2019
- - Dernière réponse :  bouda08 - 29 août 2019 à 09:41
Bonjour,

comment concaténer des cellules qui ont le mêmes nom
https://www.cjoint.com/c/IHAoADfXJKD
Afficher la suite 

7 réponses

Messages postés
1013
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
16 septembre 2019
117
0
Merci
Bonjour
Un exemple
https://www.cjoint.com/c/IHApz5dB1Oh
Crdlt
cylia2015
Messages postés
16
Date d'inscription
mardi 10 juillet 2018
Statut
Membre
Dernière intervention
29 août 2019
-
merci pour votre réponse, mais je cherche de concaténer le nom avec tous ses fourni par exemple (Monsieura f1 f2) d'une façon de regrouper tous les fourni de chaque nom (pour supprimer la répétition des nom)
Commenter la réponse de JCB40
Messages postés
49854
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 septembre 2019
10658
0
Merci

Ah bon ?

J'ai cru comprendre complètement autre chose :

cylia2015, veux-tu préciser ta demande ?

cylia2015
Messages postés
16
Date d'inscription
mardi 10 juillet 2018
Statut
Membre
Dernière intervention
29 août 2019
-
merci pour votre réponse, mais je cherche de concaténer le nom avec tous ses fourni (par exemple pour le monsieurA je veux concanener f1 f2, pour le monsiers b ,concatener f3 f4 5 f6 f7 f8 f9 f10) d'une façon de regrouper tous les fourni de chaque nom (pour supprimer la répétition des nom)
cylia2015
Messages postés
16
Date d'inscription
mardi 10 juillet 2018
Statut
Membre
Dernière intervention
29 août 2019
-
c'est à dire concaténer fournisseur de mémé nom ( la colonne D de ton capture d’écran)
Commenter la réponse de Raymond PENTIER
0
Merci
Bonjour,

Une proposition avec une macro ...
https://www.cjoint.com/c/IHBjWWEo0qj

Cordialement.
cylia2015
Messages postés
16
Date d'inscription
mardi 10 juillet 2018
Statut
Membre
Dernière intervention
29 août 2019
-
je veux une formule avec excel
cylia2015
Messages postés
16
Date d'inscription
mardi 10 juillet 2018
Statut
Membre
Dernière intervention
29 août 2019
-
est-ce qu'il ya une possibilités d'afficher devant chaque nom son résultat ??
Commenter la réponse de gyrus
Messages postés
1013
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
16 septembre 2019
117
0
Merci
Bonjour
Je ne pense pas que cela soit possible par formule
La meilleure solution 'est celle que gyrus te propose
Cordialement
Commenter la réponse de JCB40
Messages postés
1013
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
16 septembre 2019
117
0
Merci
C'est ce que tu obtiens avec la proposition de gyrus
https://www.cjoint.com/c/IHBnHM6X0kh
Commenter la réponse de JCB40
0
Merci
Bonjour,

Pourquoi ne pas utiliser un Tableau croisé dynamique ?
cylia2015
Messages postés
16
Date d'inscription
mardi 10 juillet 2018
Statut
Membre
Dernière intervention
29 août 2019
-
non je veux les afficher
Commenter la réponse de bouda08
Messages postés
49854
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 septembre 2019
10658
0
Merci
Alors puisque tu ne veux ni macro, ni tableau croisé dynamique, il faut procéder ainsi :
1) En C2 mettre la formule =SI(NBCAR(D2)<NBCAR(D3);"";D2).
2) En D2 mettre la formule =SI(A2=A1;D1&B2;A2&" : "&B2).
3) Recopier ces 2 formules vers le bas.
4) Masquer la colonne D ( et surtout ne pas la supprimer ! )
https://www.cjoint.com/c/IHCaryAYXfZ
cylia2015
Messages postés
16
Date d'inscription
mardi 10 juillet 2018
Statut
Membre
Dernière intervention
29 août 2019
-
Merci beaucoup ça fonctionne !!!!!!

Super ,
> cylia2015
Messages postés
16
Date d'inscription
mardi 10 juillet 2018
Statut
Membre
Dernière intervention
29 août 2019
-
Bonjour

Raymond PENTIER a fait un super boulot, mais n'oubliez pas de mettre à jour les formules si un fournisseur ou un monsieur venait à être modifié.


Bonne journée
Commenter la réponse de Raymond PENTIER