Resultat d'une sommeprod = 0 se transforme en #NA [Résolu]

Messages postés
13
Date d'inscription
vendredi 16 août 2019
Statut
Membre
Dernière intervention
21 août 2019
- - Dernière réponse : AdrielCohen
Messages postés
13
Date d'inscription
vendredi 16 août 2019
Statut
Membre
Dernière intervention
21 août 2019
- 21 août 2019 à 19:03
Bonsoir à Tous,

Je suis en train de créer un fichier Excel avec deux colonnes et un graphique en courbe.

Ca se présente comme ceci:

Date CA
01/01/99 1000€
02/01/99 1200€
.
.
.
31/12/99 980€

Mon graphique retrace l'évolution de mon CA en fonction du temps.

Le problème c'est que ma colonne CA est une copie incrémentale de:

=SOMMEPROD(('RC2019'!$B$3:$B$1000=$A14)*('RC2019'!$F$3:$F$1000>0)*('RC2019'!$F$3:$F$1000))

Du coup, vu que je ne travaille pas le samedi et le dimanche, je me retrouve avec des 0 en chaque fin de semaine sur mon graphique et j'aimerai que les valeurs 0 soient ignorées pour avoir une idée plus claire de l'évolution du CA.

J'aimerai donc intégrer une condition dans ma formule SOMMEPROD pour que si le résultat est égale à 0, la cellule affiche le message d'erreur #NA pour que mon graphique l'ignore enfin, mais je vois pas comment faire...

Merci pour votre aide précieuse!

Adriel
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
24565
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2019
4822
1
Merci
Bonjour
si vous voulez afficher #/les WE pour rempolacer les 0, essayez ceci:
=SI(JOURSEM($A14;2)>5;#N/A;SOMMEPROD(('RC2019'!$B$3:$B$1000=$A14)*('RC2019'!$F$3:$F$1000>0)*('RC2019'!$F$3:$F$1000)))

ou encore selon les cas:
=SI(SOMMEPROD(('RC2019'!$B$3:$B$1000=$A14)*('RC2019'!$F$3:$F$1000>0)*('RC2019'!$F$3:$F$1000))=0;#N/A;SOMMEPROD(('RC2019'!$B$3:$B$1000=$A14)*('RC2019'!$F$3:$F$1000>0)*('RC2019'!$F$3:$F$1000)))

crdlmnt



Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62632 internautes nous ont dit merci ce mois-ci

AdrielCohen
Messages postés
13
Date d'inscription
vendredi 16 août 2019
Statut
Membre
Dernière intervention
21 août 2019
-
Parfait, j'avais pas pensé à rajouter un SI devant!!

Au top, merci beaucoup!
Commenter la réponse de Vaucluse
Messages postés
1101
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
12 octobre 2019
133
0
Merci
Bonsoir

Dans excel >>options >>options avancées>>options affichage de la feuille de calcul>>>
décocher Afficher un zéro dans les cellules de valeurs nulles
Cordialement
AdrielCohen
Messages postés
13
Date d'inscription
vendredi 16 août 2019
Statut
Membre
Dernière intervention
21 août 2019
-
Bonsoir,

Je n'ai pas précisé je suis sur mac et excel version 16.28.
J'ai deja vu ce procédé mais je ne vois pas la touche option...

Merci
Commenter la réponse de JCB40
Messages postés
1101
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
12 octobre 2019
133
0
Merci
Tu peux t'inspirer de cette formule à adapter a ton fichier

=SOMMEPROD(($CC$18:$CC$20=CF5)*($CB$18:$CB$20>=MOIS(Presentation!$AB$22))*(SIERREUR(CF18:CF20;0)*CJ18:CJ20))

ne pas oublier de faire CTL-Shft-Enter formule matricielle
Commenter la réponse de JCB40