Somme si + critère de date [Résolu]

Messages postés
13
Date d'inscription
vendredi 16 août 2019
Statut
Membre
Dernière intervention
21 août 2019
-
Bonsoir à Tous,

J'ai beau chercher sur tout les forums, je ne trouve pas la solution, j'espère que vous pourrez m'aider.

J'ai une colonne B avec des dates 01/01/2000 en format date longue (Lundi 1 janvier 2000) et une colonne F avec des nombres format comptabilité correspondant à des encaissements le tout dans une feuille appelée "RC2019".

J'aimerai savoir quel jour de la semaine je fais le plus d'encaissements donc je voudrais faire la somme des montants des encaissements en fonction des jours de la semaine correspondant.

J'ai essayé:

=SOMMEPROD((GAUCHE('RC2019'!B:B;5)="lundi")*('RC2019'!F:F))
=SOMME.SI('RC2019'!B:B;"lundi*";'RC2019'!F:F)
=SOMME(SI(JOURSEM('RC2019'!$B:$B;2)=1;'RC2019'!$F:$F))

Avec et sans les $ et en essayant ctrl+maj+entré, rien ne marche...

Merci d'avance pour votre temps,
Adriel
Afficher la suite 

2 réponses

Meilleure réponse
1
Merci
Bonsoir,

Essaie avec une formule du type
=SOMMEPROD((JOURSEM(B2:B36;2)=1)*(C2:C36))

Cordialement

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62878 internautes nous ont dit merci ce mois-ci

AdrielCohen
Messages postés
13
Date d'inscription
vendredi 16 août 2019
Statut
Membre
Dernière intervention
21 août 2019
-
Bonsoir,

Merci pour votre réactivité, ça marcha à la perfection.
Tant que j'y suis, comment je fais pour rajouter la condition que la colonne C de ta formule doit être positive?

Merci d'avance,
Adriel
Commenter la réponse de gyrus
Messages postés
13
Date d'inscription
vendredi 16 août 2019
Statut
Membre
Dernière intervention
21 août 2019
0
Merci
Merci beaucoup, ça marche à la perfection!
madmyke
Messages postés
42797
Date d'inscription
lundi 21 janvier 2008
Statut
Modérateur
Dernière intervention
14 octobre 2019
6817 -
Bonjour

Merci d'avoir participé à ce forum.
Il semble que votre problème ai trouvé une réponse.

Si la réponse vous satisfait je vous invite à la mettre en résolue, c'est très simple.

Merci de cliquer sur >CE LIEN<


Cordialement
Commenter la réponse de AdrielCohen