Insérer une valeur si 2 cellules ident.à condi. qu'elles ne soient pas vides

- - Dernière réponse : Raymond PENTIER
Messages postés
49649
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 août 2019
- 12 août 2019 à 23:51
Bonjour,



Bonjour,

j'ai un petit souci:
Je veux comparer 2 cellules, si celles-ci sont identiques (même contenu), alors j'affiche 1 sinon 0. Avec cette formule, ça fonctionne : =SI(L14=E14;1;0)
Le problème c'est quand elles sont vides, cela m'affiche aussi 1 alors que je voudrais que cela m'affiche 0.

Là, je sèche.

Si qq'un a une idée, j'en serai fort reconnaissant.
Je précise que mes cellules L14, E14, etc. contiennent des noms de villes ou alors je les laisse vides.

Merci d'avance.
Afficher la suite 

3 réponses

Meilleure réponse
1
Merci
Salut Via55,

et merci pour ta réponse, effectivement, ça fonctionne.

Entre temps, j'ai trouvé une autre formule dans un ancien tableur qui a l'air de fonctionner, c'est:
=SI(L14="";"";SI(E14=L14;1;"")).

Dis moi ce que tu en penses..

Encore merci;

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59152 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Barnab
Messages postés
49649
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 août 2019
10464
1
Merci
Elles fonctionnent toutes les deux.
On peut même se contenter de
=SI(ET(L14=E14;L14<>"");1;0)
Et comme tu es sympa, je t'offre celle-ci :
=(L14=E14)*(L14<>"")
C'est un exercice très instructif que d'optimiser une formule afin qu'elle soit la plus courte possible, surtout quand elle est recopiée à des centaines d'exemplaires dans la feuille ...

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59152 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Raymond PENTIER
Messages postés
10975
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
23 août 2019
1373
0
Merci
Bonjour

=SI(ET(L14=E14;L14<>"";E14<>"");1;0)
doit faire le job

Cdlmnt
Via
Commenter la réponse de via55