Formule =couleur non automatique

Messages postés
2
Date d'inscription
vendredi 9 août 2019
Statut
Membre
Dernière intervention
12 août 2019
- - Dernière réponse : via55
Messages postés
10967
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 août 2019
- 12 août 2019 à 14:44
Bonjour,

je suis occupée à créer un tableau dans lequel j'ai ajouté l'outil développeur pour calculer des sommes de cellules selon leur couleur.

J'ai réalisé toutes les formules, les calculs, tout est ok

le seul bug : lorsque je change la couleur d'une case (je la passe de blanc à bleu) la case de référence avec la formule =couleur(B7) ne change pas automatiquement, ce qui fausse mes calcul finaux.

Je suis allée dans option/formule/Calcul automatique La case est bien cochée.
Que puis-je faire ?


Merci d'avance pour vos éclairages
Afficher la suite 

2 réponses

Messages postés
10967
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 août 2019
1371
0
Merci
Bonjour

Comment effectues tu la somme
par une fonction personnalisée ?
en lançant une macro ?

Tu peux forcer le calcul de la feuille lors d'un changement de selection en rajoutant cette macro dans el worsheet de la feuille :
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
ActiveSheet.Calculate
End Sub

Cdlmnt
Via
ririane1
Messages postés
2
Date d'inscription
vendredi 9 août 2019
Statut
Membre
Dernière intervention
12 août 2019
-
Bonjour,

j'effectue une somme en indiquant moi-meme les cases à sommer : =NB.SI(C7:C29;COULEUR($A$1))

Je suis plutôt novice donc le worksheet de la feuille je ne vois pas ce que c'est désolée ...

Merci d'avance
Commenter la réponse de via55
Messages postés
10967
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 août 2019
1371
0
Merci
Bonjour

COULEUR doit être une fonction personnalisée
Poste un exemple de ton fichier sur le site mon-partage.fr, copie le lien créé et reviens le coller ici

Dans l'attente
Cordlmnt
Via
Commenter la réponse de via55