Somme sur sélection de plusieurs critères [Résolu]

- - Dernière réponse :  Salim - 7 août 2019 à 14:54
Bonjour,

J'aurais une question relative à une fonction Excel pour une somme svp.

J'ai d'une part une base exhaustive dans un premier onglet (1) sur le champ C6:E120. Dans la colonne C des codes et dans la colonne E des chiffres.

J'ai ensuite un second onglet qui reprend en colonne C4:120 un certain nombre de codes du premier onglet mais pas tous. Je souhaiterais avoir une formule qui me permet de calculer la somme des chiffres contenus dans l'onglet 1 pour lesquels j'ai les codes dans l'onglet 2.

En espérant que ma requête est clair. Merci par avance

Salim


Configuration: Windows / Chrome 76.0.3809.100
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
55
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
21 août 2019
2
1
Merci
Ah ! alors essaie cette formule

=SOMMEPROD(SOMME.SI(Feuil1!$C$6:$C$120;Feuil2!$C$4:$C$120;Feuil1!$E$6:$E$120))

Cordialement

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59102 internautes nous ont dit merci ce mois-ci

ALS35
Messages postés
55
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
21 août 2019
2 -
De rien
Passe le sujet en Résolu
Cordialement
Commenter la réponse de ALS35
0
Merci
Bonjour,
Vous pourriez essayer ce petit tableur :
https://cjoint.com/c/IHhmdhgrgmG
Merci Oscar pour cette proposition. Ce que je souhaite avoir en fait, c'est la somme que tu as calculé mais sans étape intermédiaire. C'est à dire que tout doit être contenu dans la formule figurant en H21.

Bien à toi
@salim,
Il aurait fallu le dire...
Désolé, j'ai pas l'habitude. Merci en tout cas
Commenter la réponse de Oscar
Messages postés
55
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
21 août 2019
2
0
Merci
Bonjour,

Essaie cette formule dans la cellule D4 de ta Feuil2
=SOMME.SI(Feuil1!$C$6:$C$120;Feuil2!C4;Feuil1!$E$6:$E$120)
Remplace Feuil1 Feuil2 par les noms de tes feuilles si besoin
Attention aux symboles $
Puis recopie-la vers le bas jusqu'à la fin de ta plage

Cordialement
Merci pour ta réponse. En fait, je ne souhaite avoir une plage, mais une seule formule dans une cellule qui me donne la somme. Bien à toi
Commenter la réponse de ALS35