Prévisonnel

- - Dernière réponse :  Utilisateur anonyme - 2 août 2019 à 20:10
Bonjour,

dans un tableau budget sur excel, je voudrais que la cellule ou le montant est prévisionnel s'efface si je remplis la cellule à coté avec un nombre.

merci pour votre aide.
Afficher la suite 

7 réponses

Meilleure réponse
Messages postés
22843
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 août 2019
5596
1
Merci
Bonjour,

par formule :
=SI(A2="";ta_formule_previsionnelle;"") 

eric

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59073 internautes nous ont dit merci ce mois-ci

bonjour eriiic,

c'est nickel, j'oublie souvent de retourné le problème...

voilà affaire résolue.
merci a tous pour votre aide.
Commenter la réponse de eriiic
Messages postés
849
Date d'inscription
mercredi 24 juin 2009
Statut
Webmaster
Dernière intervention
7 août 2019
75
0
Merci
Salut,
Il faut que tu utilises la fonction
if

Voici un peu d'aide : https://exceljet.net/excel-functions/excel-if-function
++
Merci dsyren, je vais regarder ça ...
Commenter la réponse de dsyren
Messages postés
10969
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
19 août 2019
1371
0
Merci
Bonjour,

2 possibilités :
soit cacher le montant par une mise en forme conditionnelle basée sur le fait qu'il y ait une nombre dans la cellule voisine qui mettre l'écriture en blanc (si le fond de ta cellule est bien blanc)
soit effacer carrément le montant mais cela ne peut se faire que par une macro en VBA

Cdlmnt
Via
bonjour via55,

oui c’était ma première idée...
mais du coup il reste la valeur et donc ça reste prévisonnelle.

mais merci.
Commenter la réponse de via55
Messages postés
10969
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
19 août 2019
1371
0
Merci
Bon et bien une macro simple pour effacer
Fournis ton fichier en le postant sur mon-partage.fr, copie le lien créé et reviens le coller ici, je mettrai en place la macro
Commenter la réponse de via55
0
Merci
@Eriiic

Bonjour,
Désolé mais à ma grande honte, je ne comprends pas votre formule.
Pourriez vous l'expliciter "pour les nuls" dans mon genre ?
Merci d'avance.
=SI(F13="";7,43;"")
=si (la cellule F13 est égale a rien (donc vide) alors 7.43€ (en prévisionnel) sinon rien
Commenter la réponse de Utilisateur anonyme
0
Merci
@carmaloo
Merci de votre réponse. Dans mon idée, un budget c'est un tableau avec deux colonnes, une pour le Prévisionnel et une pour le Réel. En début de mois, on renseigne toutes les rubriques avec leur montant prévisionnel, puis en cours ou en fin de mois on saisit le montant réel de chaque rubrique, comme sur l'image ci dessous.
Selon la demande initiale, si j'ai bien compris, il faudrait que pour chaque rubrique, lorsqu'on saisit le montant réel, le montant prévisionnel s'efface, d'où la formule qui me tracasse.
Pourriez vous me dire où vous devez l'inscrire ?


Ps : si j'avais été chargé de la confection de ce tableau, j'aurais plutôt employé la méthode de MFC du post 3 de via55 que je salue...
par exemple en B6 vous rentrez la formule
=SI(C6="";800;"") et quand vous inscrirez le reel dans C6 la cellule B6 s'effacera.
Commenter la réponse de Utilisateur anonyme
0
Merci
Cela revient donc à saisir le montant prévisionnel de chaque rubrique dans la formule.
Pour un budget familial de quelques rubriques je veux bien, mais pour le budget d'une entreprise qui suppose des centaines de lignes, cela ne me paraît pas très pratique. Mais si cela vous convient, vous êtes seul juge.
Cordialement.
Commenter la réponse de Utilisateur anonyme