Condition si Num si Alpha

Messages postés
577
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
2 août 2019
- - Dernière réponse : danielc0
Messages postés
638
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
17 août 2019
- 2 août 2019 à 13:10
Bonjour mes amis,

Est ce que vous pouvez m'aider a trouver une formule conditionnelle,
Si le premier caractere est num donc je recois "4411"

et si le premier caractere est Alpha je recois "342&la cellule contient le premier caractere"

j'ai essayé cette formule, mais elle ne marche pas,

= SI (ISERR (GAUCHE (A2,1) * 1), "4411", 342&A2)


Exemple: si je mes à A2= 4411 je dois recevoir 4411

et si je mes à A2= Paris je dois recevoir 342Paris

Merci infiniment
Afficher la suite 

1 réponse

Messages postés
638
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
17 août 2019
43
0
Merci
Bonjour,

Remplace ISERR par ISNUMBER.

Cordialement.

Daniel
nonossov
Messages postés
577
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
2 août 2019
-
Tjrs ne marche pas est ce que vous pouvez me donner la formule complete?
danielc0
Messages postés
638
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
17 août 2019
43 > nonossov
Messages postés
577
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
2 août 2019
-
Oui. ISERR comme ISNUMBER est destiné à une version anglaise d'Office. Ta formule est un mix des deux ? La formule pour la version française est :

=SI(ESTNUM(GAUCHE(A2;1)*1);"4411";342&A2)

Eventuellement, remplace les ";" par des "",".

Daniel
Commenter la réponse de danielc0