Compter le nombre d'éléments différents d'une colonne sous condition

- - Dernière réponse :  tintin - 31 juil. 2019 à 19:15
Bonjour,
je souhaite compter le nombre d'Espece différentes par Lieu. J'ai essayé la formule suivante dans la cellule G2, sans résultat...
=SOMMEPROD((A2:A1235=F2)*(B2:B1235<>"")/NB.SI(B2:B1235;B2:B1235&""))

Quelqu'un pourrait-il me donner la solution avec le fichier joint?
https://www.cjoint.com/c/IGFqvqKPmld

Merci d'avance!
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
10968
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 août 2019
1371
1
Merci
Bonjour

https://mon-partage.fr/f/LpxLqpYF/

Attention formule matricielle à valider par Ctrl+Maj+Entrée (et la formule se met auto entre accolades dans la barre de formules=

Cdlmnt
Via

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 58112 internautes nous ont dit merci ce mois-ci

Commenter la réponse de via55