FORMULE EXCEL

Messages postés
14
Date d'inscription
mercredi 31 juillet 2019
Statut
Membre
Dernière intervention
6 août 2019
- - Dernière réponse : via55
Messages postés
10932
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
9 août 2019
- 31 juil. 2019 à 16:13
Bonjour à tous,

Je souhaite procéder à une moyenne sur des cellules non consécutives sur un tableau.

par exemple : H10; H13; H16;H19,H22;H25;H28

Les sommes dans ces cellules, proviennent d'une formule en rechercheV =SIERREUR(RECHERCHEV($A8;'ETUDE LOC'!$A$2:$AT$300;11;FAUX);0)

Avant cette recherche V, les informations étaient saisies directement et aucun problème avec cette formule : =SI(NB(H10;H13;H16;H19;H22;H25;H28)=0;0;MOYENNE(H10;H13;H16;H19;H22;H25;H28))

Malgré plusieurs essais de formule, il prend toujours en compte toutes les cellules et bien sûr ma moyenne est fausse.

En grand merci pour votre aide.



Configuration: Windows / Chrome 62.0.3202.62
Afficher la suite 

4 réponses

Messages postés
10932
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
9 août 2019
1361
0
Merci
Bonjour

Le problème vient sans doute que ta formule retourne un 0 en cas de SIERREUR qui est donc compté pour faire la moyenne
Fais retourner un symbole ou une lettre en cas de SI ERREUR et ton problème devrait être résolu

Cdlmnt
Via
Commenter la réponse de via55
Messages postés
24
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
7 août 2019
1
0
Merci
Bonjour,

Peut-être que ton problème vient du SIERREUR qui encapsule le RECHERCHEV.
Essaie de remplacer dans tes formules le 0 par ""
=SIERREUR(RECHERCHEV($A8;'ETUDE LOC'!$A$2:$AT$300;11;FAUX);"")
La fonction MOYENNE prend en compte les 0 mais pas les cellules contenant "", ce qui donne un résultat différent

Bon courage
jackmofr
Messages postés
14
Date d'inscription
mercredi 31 juillet 2019
Statut
Membre
Dernière intervention
6 août 2019
-
Bonjour ALS,

J'ai déja fait avec ... FAUX);"") .... "0"... Quand je fais FAUX);"R") ... je m’aperçois qu'un "R" appariait uniquement sur les lignes où je n'ai pas de recherche. A partir du moment où une rechercheV est demandée mais qu'il n'y a pas de données, ça le prend en compte
Commenter la réponse de ALS35
Messages postés
10932
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
9 août 2019
1361
0
Merci
Essaie :
=SI(RECHERCHEV($A8;'ETUDE LOC'!$A$2:$AT$300;11;FAUX)>0;RECHERCHEV($A8;'ETUDE LOC'!$A$2:$AT$300;11;FAUX);"")
jackmofr
Messages postés
14
Date d'inscription
mercredi 31 juillet 2019
Statut
Membre
Dernière intervention
6 août 2019
-
Bonjour via55

J'ai repris ta formule, elle fonction que si il y a une rechercheV. dans la ligne où il n'y a pas de rechercheV il apparaît #N/A
jackmofr
Messages postés
14
Date d'inscription
mercredi 31 juillet 2019
Statut
Membre
Dernière intervention
6 août 2019
-
Commenter la réponse de via55
Messages postés
10932
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
9 août 2019
1361
0
Merci
Tu rajoutes le SIERREUR comme avant pour la casd u N/A
Commenter la réponse de via55